Results 1 to 17 of 17

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Custom Carrier name disappeared?

  1. #1
    Default Custom Carrier name disappeared?
    Ok so I'm using an unjailbroken iPhone 4 on 4.0.1, When I got the phone I installed a backup from my jailbroken 3GS and I had a custom carrier. Yesterday I rebooted my iPhone and all of a sudden the AT&T carrier name came back and mine disappeared! I've rebooted my phone a couple of times before and this never happened. Any ideas why?

  2. #2
    Many of the Locations for status bar icons have moved around in 4.0, so most Custom Carrier logos don't work
    Name? whereswaldo
    iDevice + Firmware? 32GB Black iPhone 4 iOS 5.0
    Computer + OS? Dell Inspiron 15R 2nd Gen i5, 2.3 Ghz, 750GB HDD, 8GB RAM Windows 7 HP
    Location? Toronto
    Found yet? No

  3. #3
    Quote Originally Posted by whereswaldo View Post
    Many of the Locations for status bar icons have moved around in 4.0, so most Custom Carrier logos don't work
    Yea but mine was working since I got the iPhone 4, after I installed 4.0.1 it was still there! I've shut down my phone a handful of times after that and the custom carrier always was there! All of a sudden yesterday I turned off my phone powered it back on and it was gone! That's what I'm not understanding?

  4. #4
    Sounds weird, did it stop working after a winterboard update

  5. #5
    Quote Originally Posted by whereswaldo View Post
    Sounds weird, did it stop working after a winterboard update
    My iPhone is unjailbroken, so I don't have winterboard at all!

  6. #6
    Then how did you have a custom carrier

  7. #7
    Quote Originally Posted by whereswaldo View Post
    Then how did you have a custom carrier
    Because when I set up my phone I used a backup from a jailbroken 3GS!

  8. #8
    When you were jb'ed, did you have a custom carrier from a winterboard theme or from SSHing an replacing the original?

  9. #9
    Quote Originally Posted by whereswaldo View Post
    When you were jb'ed, did you have a custom carrier from a winterboard theme or from SSHing an replacing the original?
    Neither I used the Make It Mine app!

  10. #10
    Then it should be there, unless Apple had some tricks up their sleeve. You can always fix it by jaibreaking

  11. #11
    Quote Originally Posted by whereswaldo View Post
    Then it should be there, unless Apple had some tricks up their sleeve. You can always fix it by jaibreaking
    LOL, that's what's weird about it it should be there and it's not! I haven't synced the phone since 4.0.1 came out so it can't be that! I dunno how my phone would automatically switch it back when I rebooted it! Still scratching my head here! I'm waiting to jailbreak until all the bugs and kind are worked out and when there r a couple of themes for the iPhone 4! Thnks again for you input!

  12. #12
    Well it's your lucky day, the bugs are worked out and there are a couple themes, the only
    Problems are non compatible apps

  13. #13
    I used Make it mine and cant get my At&t icon to come back... even after I tried to clear it, and even changing it to AT&T, then restoring my iphone, its still the same. Does anyone know where this particular file is when I SSH in so I can change it back? Make it mine has kind of screwed me over here because its a straight giveaway that Ive jailbroken. Lol.

  14. #14
    I believe the 2 carrier logos are in /System/Library/CoreServices/Springboard.app and you can replace them, but I recommend you backup the normal ones

  15. #15
    Quote Originally Posted by TWOGUNZ View Post
    Ok so I'm using an unjailbroken iPhone 4 on 4.0.1, When I got the phone I installed a backup from my jailbroken 3GS and I had a custom carrier. Yesterday I rebooted my iPhone and all of a sudden the AT&T carrier name came back and mine disappeared! I've rebooted my phone a couple of times before and this never happened. Any ideas why?
    It's due to signature check on carrier.plist by commcenter of iOS 4.0/4.0.1, the custom carrier bundle loaded by iTunes from a 3.x backup is not compatible with iOS 4.0/4.0.1, carrier bundle required version is 7. and should be signed by Apple.

    You can get around this after JB and using Wortel's commcenter patch.

  16. #16
    Quote Originally Posted by aneagle View Post
    It's due to signature check on carrier.plist by commcenter of iOS 4.0/4.0.1, the custom carrier bundle loaded by iTunes from a 3.x backup is not compatible with iOS 4.0/4.0.1, carrier bundle required version is 7. and should be signed by Apple.

    You can get around this after JB and using Wortel's commcenter patch.
    Ok so why was I on version 4.0.1 on a iPhone 4 unjailbroken with a custom carrier! I don't think u guys r understanding me! I already had a custom carrier on my iPhone 4(not jailbroken) when the phone first came out, I updated to 4.0.1 the day it came out and after that I still had the custom carrier! That was over a month ago! Just yesterday is when my carrier dissapeared without me syncing my iPhone to iTunes! How would the phone automatically delete the custom carrier?

  17. #17
    ^ I'm understanding you, unlike the guy your quoting. But I am straight up stumped on why and how it could happen

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •