Page 20 of 35 FirstFirst ... 10181920212230 ... LastLast
Results 381 to 400 of 688

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 Battery DRAIN!! After Jailbreak.

  1. #381
    I left my iPhone 4 on stand by for 8 hours and 45 minutes (overnight), and it drained from 100% to 85%...

    It was connected to a 2G network, WiFi was on, with these running processes:


  2. #382
    Quote Originally Posted by .matt View Post
    I left my iPhone 4 on stand by for 8 hours and 45 minutes (overnight), and it drained from 100% to 85%...

    It was connected to a 2G network, WiFi was on, with these running processes:

    Was push mail turned on whilst on wifi? try turning push mail off whilst on wifi and try again. I bet you the drain will be gone.

  3. #383
    yay... battery life looking good now.. 2 hours with 1% loss. =D

    great update!!

  4. #384
    Quote Originally Posted by PSI70Y View Post
    Was push mail turned on whilst on wifi? try turning push mail off whilst on wifi and try again. I bet you the drain will be gone.
    Hmm, I'll try that, and report back!



    Quote Originally Posted by milesming View Post
    yay... battery life looking good now.. 2 hours with 1% loss. =D

    great update!!
    How did you fix your problem?

  5. #385
    Quote Originally Posted by .matt View Post

    Hmm, I'll try that, and report back!
    Please. I still think there is WiFi and push mail issue. But I think it only affects some devices as other people dont have this issue.

    I have eliminated everything else and this is the only battery drain which I can reproduce (and eliminate).

    I've been banging on about it quite a bit, but the more people that test it the better.

  6. #386
    PSI70Y,
    Do you mean to say that somehow push mail is causing a major drain while wifi is on? Just push for mail or all push?
    Most of my drain occurs while off a wifi network (but wifi is still enabled).
    Literally five minute of Angry Birds just caused 7% of battery to go down.

    I should also say that I had a "normal" Gmail account set up yesterday, with the same drain, and wifi push mail works just fine for me, no lag.

  7. #387
    Quote Originally Posted by PSI70Y View Post
    Please. I still think there is WiFi and push mail issue. But I think it only affects some devices as other people dont have this issue.

    I have eliminated everything else....
    Mind sharing with us what you've eliminated?

    Thanks!

  8. #388
    Quote Originally Posted by kidblue View Post
    PSI70Y,
    Do you mean to say that somehow push mail is causing a major drain while wifi is on? Just push for mail or all push?
    Most of my drain occurs while off a wifi network (but wifi is still enabled).
    Literally five minute of Angry Birds just caused 7% of battery to go down.

    I should also say that I had a "normal" Gmail account set up yesterday, with the same drain, and wifi push mail works just fine for me, no lag.
    I only notice a battery drain when push mail is enabled. When I get home and switch from 3G to WiFi, i turn push mail off (and leave push notifications on) and I dont experience the battery drain.

    I have restored to new phone and applied JB with no data on the phone and reloaded all apps and then synced my data(contacts, calendar, etc).

    I am also running 3228 MS, sbsettings, iprotect, springflash and various others MS extensions and push mail whilst on wifi is my only battery drain

    Quote Originally Posted by .matt View Post
    Mind sharing with us what you've eliminated?

    Thanks!
    Im in Australia, so i bought a factory unlocked iP4, so no need for ultrsn0w. I did buy signal and had it installed, but have removed it (this was before fix).

    And like I said in my previous post I restored phone to new and loaded all latest MS and extensions so it does not appear to be any of them. For eg I think i only lost 1% during the night over a 7 hour period in standby (wifi off, push off, 3g off) so I def do not think I have a battery drain issue. And I also acknowledge the fact that a JB phone will use more juice than a jailed one. Whether I look at it more or it now does more things or due to all the extensions and extra code running on it, dunno but its just what I have experienced.
    Last edited by PSI70Y; 2010-08-12 at 02:39 AM. Reason: Automerged Doublepost

  9. #389
    PSI70Y,
    Still trying to grasp where you're at with this:
    Even with a "normal" Exchange/Gmail et-up, just just disable push (and set to poll/fetch?) and see battery return to normal? No other issues with other notifications?
    By your theory, leaving wifi on and push mail off permanently would "fix" the drain?
    And you couldn't eliminate ultrasn0w because you're unlocked, right?

  10. #390
    Quote Originally Posted by PSI70Y View Post
    I only notice a battery drain when push mail is enabled. When I get home and switch from 3G to WiFi, i turn push mail off (and leave push notifications on) and I dont experience the battery drain.

    I have restored to new phone and applied JB with no data on the phone and reloaded all apps and then synced my data(contacts, calendar, etc).

    I am also running 3228 MS, sbsettings, iprotect, springflash and various others MS extensions and push mail whilst on wifi is my only battery drain



    Im in Australia, so i bought a factory unlocked iP4, so no need for ultrsn0w. I did buy signal and had it installed, but have removed it (this was before fix).

    And like I said in my previous post I restored phone to new and loaded all latest MS and extensions so it does not appear to be any of them. For eg I think i only lost 1% during the night over a 7 hour period in standby (wifi off, push off, 3g off) so I def do not think I have a battery drain issue. And I also acknowledge the fact that a JB phone will use more juice than a jailed one. Whether I look at it more or it now does more things or due to all the extensions and extra code running on it, dunno but its just what I have experienced.
    I see! If the battery still drains when push mails is disabled, I should try restoring as well.

    I'm in a country that doesn't sell locked phones, so I don't need Ultrasn0w either- I'll remove Signal.app for now, and see if there's any improvement

    Another question: what's 'MS' ?

    Thanks!
    Last edited by .matt; 2010-08-12 at 02:43 AM.

  11. #391
    Quote Originally Posted by .matt View Post


    I see! If the battery still drains when push mails is disabled, I should try restoring as well.

    Another question: what's 'MS' ?

    Thanks!
    Yeah I would, but when you do set up your phone as a new phone, do not restore from backup. Bad point is you loose all ur sms and in-app data (unless you use appbackup or something similar)
    then apply JB and start again. I hope you saved your SHSH as the JB wont work for 4.0.2

    MS is Mobile Subrate, used for things like iProtect, SBSettings, biteSMS, Signal, ultrasn0w, etc. Its just a code insertion system.

  12. #392
    Quote Originally Posted by PSI70Y View Post
    Yeah I would, but when you do set up your phone as a new phone, do not restore from backup. Bad point is you loose all ur sms and in-app data (unless you use appbackup or something similar)
    then apply JB and start again. I hope you saved your SHSH as the JB wont work for 4.0.2

    MS is Mobile Subrate, used for things like iProtect, SBSettings, biteSMS, Signal, ultrasn0w, etc. Its just a code insertion system.
    Oh noes. I just got my iPhone (first), so I'm all new to this 'jailbreak' thing

    I'll try googling for a 4.0.1 ipa <- correct?

    Thanks!

  13. #393
    Quote Originally Posted by .matt View Post
    Oh noes. I just got my iPhone (first), so I'm all new to this 'jailbreak' thing

    I'll try googling for a 4.0.1 ipa <- correct?

    Thanks!
    Apple are still signing 4.0.1, you dont need to download anything.

    google tinyumbrella. download it and use it, save your SHSH blob both to your computer and cydia. This will enable you to always downgrade back to 4.0.1 so you can always use the current JB

    To restore, simply plug phone into itunes and click on restore. Itunes will still download 4.0.1 and restore your phone to new.

    MAKE SURE ITS 4.0.1. but use tinyumbrella first before you do anything. Do it now, apple will stop signing 4.0.1 soon

  14. #394
    Sorry, why are we suggesting to restore at the moment?

  15. #395
    Quote Originally Posted by kidblue View Post
    Sorry, why are we suggesting to restore at the moment?
    regardless he should use tinyumbrella straight away.

    I said if I was still having major battery drain, it was my opinion that I (personally) would restore.

    He is free to continue installing/uninstalling packages to see what the issue is. I have found (again personally) that my only battery drain is WiFi and push(gmail). I have the latest MS and various extensions and dont experience battery drain.
    Last edited by PSI70Y; 2010-08-12 at 02:57 AM.

  16. #396
    Truth to that - Back it up, back it up.

    I restored last night - Only installed ultrasn0w because I need it (locked carrier). I'm currently draining my battery and re-calibrating just to see if the new ultrasn0w is doing anything at all. I'd be very interested to hear what the case would be if you used it, battery-wise.

  17. #397
    Quick update from me:

    I'm still running the latest MobileSubstrate (3228 or whatever it is). I'm also running SBSettings and, as I've probably mentioned before, push Gmail is on 100% of the time, 3G is off, WiFi is on, Location Services are off unless needed (basically, I'm actually using SBSettings). I also have MyWi and WiFi Sync.

    I pulled down the update to Signal today. I reenabled "enablettydebug" before applying the update, but for some reason Signal still wasn't working right after a reboot. So I re-installed SBSettings and MS through Cydia and rebooted again and everything was kosher, Signal worked as it's supposed to again.

    Then I charged to 100% and unplugged, then killed Signal via the Apple task management/multitasking dock thing. I've left the thing alone for a few hours now, and I'm at 99% battery after 2h 11m of standby and 9m of usage, all of which was just checking the home screen and playing with Signal just a little bit (after which I killed it again). So far I am happy with this, and I think they've solved the problem with the app.

    That's not to say there aren't other 'leaks' to be found, though. Here's hoping the rest of you guys track down other issues that are still here!

  18. #398
    I had updated to the new ultrasn0w with MS 3228. I had the phone in standby 6 hour with 3G, Wifi, Push, Notification, Location all turn off the battery only drain 1%.

    But when i m using wifi it drain 1% every 3-4 min i don't know if thats normal.

  19. #399
    Quote Originally Posted by Kama1314 View Post
    I had updated to the new ultrasn0w with MS 3228. I had the phone in standby 6 hour with 3G, Wifi, Push, Notification, Location all turn off the battery only drain 1%.

    But when i m using wifi it drain 1% every 3-4 min i don't know if thats normal.
    Im bashing push mail/WiFi combo, but try turning push mail off whilst on wifi and c how the drain is.

  20. #400
    ok now i really have no doubts its perfect!!!!

    6hours standby 99%, by now whitout the update i should be around 75%

    lovely update thanks dev team

    worried whit the statment of user Kama1314
    "...But when i m using wifi it drain 1% every 3-4 min..."

    will have to test that as well

Page 20 of 35 FirstFirst ... 10181920212230 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •