Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help iPod touch 3g wont restore??

  1. #1
    Default Help iPod touch 3g wont restore??
    Hi, just got an iPod touch for my bro, but I need to update it. So I've been trying restore it but it wont restore all the way. It goes to like 95% full bar (you know when you restore the apple logo then theres a bar underneath that is getting filled as it progresses) but mine doesn't finish all the way. I tried restoring it back to 3.1.3 first, then tried 4.0 still nothing! It is an iPod touch 2nd gen, 8gb, never jailbroken to my knowledge, it didn't have Cydia on it already, but it might have been jailbroken before. I tried restoring it via iTunes first, no luck, then tried downloading the firmware through Modmyi, no luck, I checked with umbrella software to make sure it is the right gen, it says 2nd gen iPod touch, I cant get forcast from ih8snow idk the download link wont work. PLEASE HELP!!

  2. #2
    Put into DFU mode, enter iTunes, shift-click restore and select a downloaded 4.0. Make sure to set it up as a new device

  3. The Following User Says Thank You to korin125 For This Useful Post:

    piston597 (2010-08-04)

  4. #3
    Ya I fixed it, I tried DFU and Restore mode, both didn't work. I think it was my hosts file which was pointed at Saurik server and not Apple that might have caused some conflict. I just blocked out the line and it restored perfectly. Thanks though!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •