Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: WinSCP and Win7 64 bit

  1. #1
    Default WinSCP and Win7 64 bit
    Hey guys, hoping someone may have had this issue and could help me out... I am running Win7 64 bit, and using WinSCP to SSH...I try to log in, and it continuosly times out and retries, I'm talking I can set for 15 min waiting then all of sudden it will connect, and I can close it and reconnect, it will connect instantly..can actually do that several times, then I can go in and ssh something, then let it set idle for a few minutes, and it disconnects. Then back to waiting forever to connect again. Any ideas where I might look to for my problem? Thanks in advance.

  2. #2
    iPhone? More like MyPhone
    Join Date
    Dec 2008
    Location
    Ogden,Ut
    Posts
    129
    Thanks
    4
    Thanked 11 Times in 10 Posts

    Make sure that you have the auto lock turned off. I have the same setup and when the phone locks wifi turns off sometimes and disconnects it, so you have to start all over

  3. #3
    Livin the iPhone Life SharpieBandit's Avatar
    Join Date
    Sep 2008
    Location
    Alexandria, Louisiana
    Posts
    1,454
    Thanks
    53
    Thanked 76 Times in 63 Posts

    It sounds like you don't have Autolock set to Never. Also, I'm running 64-bit Win7 with no problems on WinSCP just fyi.
    Steam ID: gentrytj
    Origin ID: gentrytj
    Gamertag: TJ McHoonigan
    PSN ID: TheWyzeMan
    Twitch.TV: TJ_McHoonigan

  4. #4
    Quote Originally Posted by SharpieBandit View Post
    It sounds like you don't have Autolock set to Never. Also, I'm running 64-bit Win7 with no problems on WinSCP just fyi.
    It's not the autolock, I have it set to never, it's when I am initially trying to connect to winscp...it tries, and the gives me the reconnecting in 4 seconds screen and just keeps doing that...then all of a sudden, it will connect. After that, I'll be able to connect if I cut it off and back on, no problem, 10 min. later, I try again, and have to wait and wait for it to finally connect. I have the iPhone 4 now, was the same on my iphone 3G. Also on WinSCP ver. 4.28(Build 818), what version are you using?

    EDIT: Network Error: Connection Timed Out is the error I get.
    Last edited by iJunkie68; 2010-08-04 at 05:08 AM.

  5. #5
    Livin the iPhone Life SharpieBandit's Avatar
    Join Date
    Sep 2008
    Location
    Alexandria, Louisiana
    Posts
    1,454
    Thanks
    53
    Thanked 76 Times in 63 Posts

    I'm not sure if it would work, but try re-installing OpenSSh on your i4 and re-installing WinSCP on your computer.

    I'm also using WinSCP 4.28.


    Also, what router do you have and how old is it? You might just be having network problems.
    Last edited by SharpieBandit; 2010-08-04 at 05:18 AM. Reason: Automerged Doublepost
    Steam ID: gentrytj
    Origin ID: gentrytj
    Gamertag: TJ McHoonigan
    PSN ID: TheWyzeMan
    Twitch.TV: TJ_McHoonigan

  6. #6
    Quote Originally Posted by SharpieBandit View Post
    I'm not sure if it would work, but try re-installing OpenSSh on your i4 and re-installing WinSCP on your computer.

    I'm also using WinSCP 4.28.


    Also, what router do you have and how old is it? You might just be having network problems.
    I have a D-link DIR 615 6 months old or so. I'm not real smart on network permissions and all the setup either lol.

  7. #7
    Have you considered ifunbox? Search google. Will allow you to access the directory over USB, including the root file system. Be sure to install afc2add from cydia, or it will report the phone as jailed.
    Oh yes, did I mention, iphonebox is free?

    Another awesome program you may wish to consider. CopyTrans. AWESOME replacement for icrap (itunes) The "Suite" comes with several programs. One of free, and will allow you to manage your video's and music. You can purchase others to allow you to manage pictures, do a full system backup, etc. I only use it for the music/videos personally. In any event, take a look at it, you may like it.

  8. #8
    Quote Originally Posted by iJunkie68 View Post
    Hey guys, hoping someone may have had this issue and could help me out... I am running Win7 64 bit, and using WinSCP to SSH...I try to log in, and it continuosly times out and retries, I'm talking I can set for 15 min waiting then all of sudden it will connect, and I can close it and reconnect, it will connect instantly..can actually do that several times, then I can go in and ssh something, then let it set idle for a few minutes, and it disconnects. Then back to waiting forever to connect again. Any ideas where I might look to for my problem? Thanks in advance.
    same router, same OS, and exactly the same behavior for me as well! I thought I was the only one. Anybody can guess why this is happening?

    As for iFunbox, does it fix permissions?

  9. #9
    I've always had to try a couple times to login. The main problem is my iPod's IP changing all the time. Make sure you check to see if it has changed

  10. #10
    Nope that's not the issue for me. Not sure if it'll help you iJunkie, but I elected to reinstall openSSH on 2 of my iPhones, and after doing so, WinSCP seemed to latch on to them and hold the login as well.

    Give it a go and see if you get similar results.

  11. #11
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    I use an adhoc connection with my laptop so that I don't have to mess with routers. It uses my internal wifi card instead. Works everytime. Win7 64bit, not sure what version if winscp though.

  12. #12
    Quote Originally Posted by Bouzo View Post
    Nope that's not the issue for me. Not sure if it'll help you iJunkie, but I elected to reinstall openSSH on 2 of my iPhones, and after doing so, WinSCP seemed to latch on to them and hold the login as well.

    Give it a go and see if you get similar results.
    Gave it a try, and yes it actually seems to be doing better for now, will update if it reverts to not connecting again. Thanks for the info.

  13. #13
    BUMP...just hoping maybe someone had experienced this by now and had found a solution they could share. I have tried every single suggestion, nothing seems to be working for me. The latest I have seen with my iphone and WINSCP...some of the time, I can leave ToggleSSH open on my iphone, and when I try connecting to WinSCP, I can hit the Disable button, then the Enable button again while it's attempting to connect, and it will connect, otherwise, it will try multiple times before connecting. I'm almost sure it's something to do with my D-link DIR 615 router. Any ideas or suggestions would be greatly appreciated. I can use iFunbox and it works fine, just would really like to figure this problem out.

  14. #14
    Quote Originally Posted by iJunkie68 View Post
    BUMP...just hoping maybe someone had experienced this by now and had found a solution they could share. I have tried every single suggestion, nothing seems to be working for me. The latest I have seen with my iphone and WINSCP...some of the time, I can leave ToggleSSH open on my iphone, and when I try connecting to WinSCP, I can hit the Disable button, then the Enable button again while it's attempting to connect, and it will connect, otherwise, it will try multiple times before connecting. I'm almost sure it's something to do with my D-link DIR 615 router. Any ideas or suggestions would be greatly appreciated. I can use iFunbox and it works fine, just would really like to figure this problem out.
    Since I last posted I have found that I have also have to do the exact same thing, that is, keep flipping the toggle from ON to OFF then back ON to get it to connect otherwise I wait forever as well.

    I have not found another solution to this. \

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •