Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Push doesn't work on ios4 - no hacktivation

  1. #1
    Default Push doesn't work on ios4 - no hacktivation
    Okay i am sorry that I just wrote everything in German.. Somehow I used my first language ;D okay Now I explain again! I installed ios4 on my iPhone 3G 16gb and then set up as a new iPhone, not as a backup! Then I jailbroke with redsn0w and push doesn't work :/ I even tried push doctor and pushfix but it doesn't help me either :/



    Hey forum
    Ich habe hier ein Problem.. Mein push will einfach nicht funktionieren! Ich habe das ios4 auf meinem iPhone 3G 16 gb installiert und dann NICHT vom Backup wiederhergestellt.. Dann habe ich es mit redns0w gejailbreakt und es funktioniert nun nicht! Ich habe zwar pushfix und pushdoctor probiert aber die helfen auch nix :/
    Last edited by Marv1993; 2010-07-04 at 12:30 PM.

  2. #2
    Since your iPhone hasn't been Hacktivated, then you should use 'Push DONOR' and Not push doctor. It'll work then.


    Press Thanks! If I helped.

  3. #3
    I used Push Donor and it creates a ton of certs! When is it done doing it? I pressed stop after like an hour.. Now Push still doesnt work :/

  4. #4
    You have to install also that files, because they are the dependencies of installing the push donor itself.
    Also use the iPusher (From the Appstore) to check out whether your push notifications are working or not.
    Press Thanks! If Its Worth It!

  5. #5
    I installed that certificate Thing on my Computer and it started generating certs... What files do I have to install and how?
    Ipusher shows me that push doesn't work.. Nothing happens..

  6. #6
    Hi, Marv1993.

    Here's a very good detailed guide: Push Donor/Nimble+Inject | [cmdshft]

    By the way, according to the guide, it seems that it is not as simple as if you activated via iTunes or hactivated. It says that if you used Backra1n, it installed a fake cert, which remains even if you activate via iTunes.

    I'm wondering if this is the problem for me. I was using 3G 3.1.2, which was blackra1n'ed. Then, I updated to 4.1 using sn0wbreeze 2.0.1. I don't think I hactivated because I'm with ATT, but if there's a way for us to check whether we are activated or hactivated or if the problem is caused by the left-over install from blackra1n, it could be very helpful. Any tipes anyone?

  7. #7
    Hacktivation is not using iTunes to activate normally

    If you are on an official carrier when jailbreaking, you do not need to install push doctor (or push donor, that only supplies our servers with new certs from your device to help push doctor do its thing).

    So unless you also unlock your iPhone, you don't need push doctor.

  8. #8
    Yea, but unfortunately, push is not working, so we are trying to troubleshoot this somehow.

    I just tried using iPusher, and it tells me Push is working. I don't know how reliable this app is, but if this is the case, I wonder if the problem is specific to iOS4.1 on 3G rather than JB or Hactivation issues. I see others having the same problem with non-hactivated phones.

  9. #9
    If you are having issues with push on a legit activated device, push doctor will NOT fix it.
    Last edited by cmdshft; 2010-09-30 at 02:05 AM. Reason: Typo

  10. #10
    Yea, most of us know that. We were talking about push donor, not doctor

  11. #11
    Quote Originally Posted by GoldenTequila View Post
    Yea, most of us know that. We were talking about push donor, not doctor
    Push Donor wont help you either. All that does is take a iTunes activated phone, extract and zip it's push certs, upload them to a remote server to be used by Push Doctor. Then it deactivates the phone, resprings it and reactivates the phone via iTunes to do it all over again.

    Make sure you don't have anything that kills apsd (like the old apsd sbsettings toggle, you should install the newest version), as this can cause push issues. Other than that, obviously double check your settings, network settings, etc. If you have a legit activated phone, try using a push enabled app before jailbreaking and see what happens. If it doesn't work, call Apple.

  12. #12
    Yea, I think many of us know that too. But, the problem is not what we know but what we don't know, and unfortunately nobody knows why this is happening at the moment (and to many). In such case, trial and error is one way to troubleshoot, especially when nobody has the answer. We are also assuming that everybody has this issue from the same cause, which may not be the case. Not to mention, some of them may have ticked the hactivation box without awareness and think their phone is genuine when it is not. So, when there's a problem that has multiple possible causes, it's kinda dangerous to "assume" otherwise and tell to the world that something is not going to fix it. It could prevent people whose issues could indeed have been fixed. Just my 2 cents. By the way, though I have not used it personally, thank you for making softwares like those. I have much respect and appreciation for developers

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •