Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4: Proximity sensor is f'd up!

  1. #1
    Default iPhone 4: Proximity sensor is f'd up!
    I hope I spelled that right? I know I've seen people discussing this before but hadn't paid much attention to it until now...I was just using my phone and was cradeling it between my ear and shoulder and I noticed the screen activated and starting pushing buttons all over the keypad...my other iPhones never did this.

    Shall we just call the entire phone a complete fail? This is unbelievable lol. Will there be a software fix for this or is this also a hardware issue?
    "Don't hold it like that!"

  2. #2
    iPhone? More like MyPhone jjr3211's Avatar
    Join Date
    Apr 2009
    Location
    ohio
    Posts
    260
    Thanks
    13
    Thanked 22 Times in 18 Posts

    mine did that when i first got it all i did was reset network settings and it workes now.

  3. #3
    Quote Originally Posted by jjr3211 View Post
    mine did that when i first got it all i did was reset network settings and it workes now.
    What does the network settings have to do with the proximity sensor? Not being smart @ss, but I don't understand the connection.
    "Don't hold it like that!"

  4. #4
    i had this happen but it was my fault, i opened my phone and replaced the case .. i must have made a rip in the cable to prox sensor which in turn messed up the speaker too .. i had to order a new cable/sensor and swapped it out .. all is well now hopefully this wasnt ur issue!

  5. #5
    Nah man I've done nothing like that. Do a google search for iPhone 4 proximity sensor...it's a mess!

    I went to my AT&T store this afternoon about this problem as well as the reception issue and there must have been 30 people in the store waiting to be helped with their iPhone issues. I would have been in there until the store closed so I left.
    "Don't hold it like that!"

  6. #6
    Green Apple JEsTer10's Avatar
    Join Date
    Oct 2007
    Location
    Arizona, USA
    Posts
    50
    Thanks
    9
    Thanked 9 Times in 8 Posts

    Did you try resetting the network setting as jjr said? I don't see the connection either, but no harm in trying as he said it worked for him, it may work for you, right?

    Quote Originally Posted by jjr3211 View Post
    mine did that when i first got it all i did was reset network settings and it workes now.
    If I helped at all, hit thanks! ------------>

    iPhone 4, you will soon be mine.

  7. #7
    Reseting network worked for me too

  8. #8
    Well ok I suppose I can try it, what exactly does that do just erase my Wi-Fi that I have programed on the phone? My local news channel just did a huge story tonight on Apple and the iPhone and the law firm in my backyard that has brought one of the many lawsuits to the table. At least the news is pimping the trouble.
    "Don't hold it like that!"

  9. #9
    Green Apple JEsTer10's Avatar
    Join Date
    Oct 2007
    Location
    Arizona, USA
    Posts
    50
    Thanks
    9
    Thanked 9 Times in 8 Posts

    I believe it will forget all Wi-Fi networks you've ever connected. It will also reset your Edge settings and forget all Bluetooth devices that you've connected to. I think that is all.
    If I helped at all, hit thanks! ------------>

    iPhone 4, you will soon be mine.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •