Ok... So I have a very odd problem. I have a Hackintosh computer, but this has never been an issue before. The computer will charge, but not recognize my iPhone (3Gs, jailbroken) or my iPod Touch (2G, not jailbroken). If I reinstall iTunes, it will recognize them the first time I run iTunes, but as soon as I quit iTunes, it will not recognize them until I reinstall iTunes. They work fine on other computers. I've run them through the motions (restore, reinstall, blah blah blah) but nothing has worked.

When I say my computer won't recognize them, here's what I mean:
They don't show up in iTunes
They don't show up in DiskAid (iPod file explorer)
They DO, however, show up in System Profiler as:
Code:
iPhone:

  Product ID:	0x1294
  Vendor ID:	0x05ac  (Apple Inc.)
  Version:	 0.01
  Serial Number:	bd2e788862658a63bc51037620fd97be********
  Speed:	Up to 480 Mb/sec
  Manufacturer:	Apple Inc.
  Location ID:	0xfd100000
  Current Available (mA):	500
  Current Required (mA):	500
(I edited the serial number... Just in case that's supposed to be private, I don't know anything about it)

Does anyone know anything at all about this? Thanks very much