Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: SSH issues

  1. #1
    iPhone? More like MyPhone mahgninnuc93's Avatar
    Join Date
    Oct 2008
    Location
    Sacramento, Ca.
    Posts
    249
    Thanks
    29
    Thanked 10 Times in 10 Posts

    Default SSH issues
    Hello all, I keep getting a time out when trying to ssh into my phone so I can add a theme.

    I out in my WiFi ip address, use root and alpine and keep getting the following error message: "Network error, connection refused"

    Any suggestions? Thanks!

  2. #2
    Are you sure that SSH is installed on your iphone and enabled?

  3. #3
    Retired Moderator battlecrushr's Avatar
    Join Date
    Jun 2009
    Location
    Houston follow @al_da_beast
    Posts
    7,940
    Thanks
    273
    Thanked 1,034 Times in 956 Posts

    Make sure ur iPhone isn't in lock mode so slide to unlock and leave it like that the whole time

  4. #4
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,207
    Thanks
    5,599
    Thanked 12,544 Times in 7,599 Posts

    to add......don't let phone sleep either.

  5. #5
    And make sure the phone is awake (3rd times a charm)

  6. #6
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,207
    Thanks
    5,599
    Thanked 12,544 Times in 7,599 Posts

    so let me see, phone can't sleep right? But can I?

  7. #7
    iPhone? More like MyPhone mahgninnuc93's Avatar
    Join Date
    Oct 2008
    Location
    Sacramento, Ca.
    Posts
    249
    Thanks
    29
    Thanked 10 Times in 10 Posts

    Hmmm....unlocked check....no sleep check...SSH showing on SBprefs in a bright and shiny green check....Yep all systems appear to be a go!!!!

  8. #8
    Sometimes rebooting your phone will help.

  9. #9
    iPhone? More like MyPhone mahgninnuc93's Avatar
    Join Date
    Oct 2008
    Location
    Sacramento, Ca.
    Posts
    249
    Thanks
    29
    Thanked 10 Times in 10 Posts

    Will do that now...please stand by LOL

    OK so I use the wi fi ip address, root and alpine and connection is refused. I am also hooked up via USB if that helps.

    Turned it off then back on and got the same error.
    Last edited by mahgninnuc93; 2009-10-11 at 06:17 AM. Reason: Automerged Doublepost

  10. #10
    What program are you using?

  11. #11
    iPhone? More like MyPhone mahgninnuc93's Avatar
    Join Date
    Oct 2008
    Location
    Sacramento, Ca.
    Posts
    249
    Thanks
    29
    Thanked 10 Times in 10 Posts

    Winscp, I am running a laptop with Xp

  12. #12
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,302
    Thanks
    349
    Thanked 1,175 Times in 724 Posts

    It's your firewall bud...... You cant expect Winderz to be intelligent enough to allow the connection past your firewall to the port without telling it really slowly and clearly what you want in your firewall settings.

    .........a mac would know what you want it to do.

    Go into your firewall settings and allow the ports needed and programs needed. If you can't get it working completely disable the firewall long enough to SSH and figure it out later. The chances of your router doing the locking are slim to none so don't bother with it's settings until you can't so anything doing everything else.

  13. #13
    it's not the firewall, since firewalls normally allow any kind of connection in the local network (the windows firewall just allows any kind of connection anywhere ).

    uninstall SSH, reboot. install SSH, reboot. then try to connect. make sure you use the correct IP and your computer and iphone are on the same network. also make sure you select SFTP as a connection method in WinSCP, not FTP or something else. that's really important.
    then wait. on first connection, it can sometimes take about 1-2 minutes until a connection is stablished.
    if you did everything correctly, it will work.

  14. The Following 2 Users Say Thank You to BlackWolf For This Useful Post:

    mahgninnuc93 (2009-10-12), Nitsson (2009-10-12)

  15. #14
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,302
    Thanks
    349
    Thanked 1,175 Times in 724 Posts

    What's the first thing winderz blocks that is part of most ssh aplications and first in this list?

    Attached Thumbnails Attached Thumbnails -picture-031.jpg  

  16. #15
    not getting it ... bonjour isn't part of SSH if that's what you mean. sorry really didn't get what you were trying to say

  17. #16
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,302
    Thanks
    349
    Thanked 1,175 Times in 724 Posts

    Connect through bonjour when you aren't able to get your ports open in ssh and make it work. It's simple troubleshooting. If you don't have the firewall setup properly you can't get in either way. You're not approaching fixing the problem the right way.

  18. #17
    Quote Originally Posted by one1 View Post
    Connect through bonjour when you aren't able to get your ports open in ssh and make it work. It's simple troubleshooting. If you don't have the firewall setup properly you can't get in either way. You're not approaching fixing the problem the right way.
    well, yeah, still ... it's not a firewall issue, so it's not the SSH port. and winSCP isn't capable of connecting through bonjour afaik. just saying ...

  19. #18
    iPhone? More like MyPhone mahgninnuc93's Avatar
    Join Date
    Oct 2008
    Location
    Sacramento, Ca.
    Posts
    249
    Thanks
    29
    Thanked 10 Times in 10 Posts

    Quote Originally Posted by BlackWolf View Post
    it's not the firewall, since firewalls normally allow any kind of connection in the local network (the windows firewall just allows any kind of connection anywhere ).

    uninstall SSH, reboot. install SSH, reboot. then try to connect. make sure you use the correct IP and your computer and iphone are on the same network. also make sure you select SFTP as a connection method in WinSCP, not FTP or something else. that's really important.
    then wait. on first connection, it can sometimes take about 1-2 minutes until a connection is stablished.
    if you did everything correctly, it will work.
    Correct BW. It was not the firewall. I followed the directions and it worked flawessly. Many thanks

  20. #19
    Quote Originally Posted by mahgninnuc93 View Post
    Correct BW. It was not the firewall. I followed the directions and it worked flawessly. Many thanks
    my pleasure ;-)

  21. #20
    Quote Originally Posted by BlackWolf View Post
    it's not the firewall, since firewalls normally allow any kind of connection in the local network (the windows firewall just allows any kind of connection anywhere ).

    uninstall SSH, reboot. install SSH, reboot. then try to connect. make sure you use the correct IP and your computer and iphone are on the same network. also make sure you select SFTP as a connection method in WinSCP, not FTP or something else. that's really important.
    then wait. on first connection, it can sometimes take about 1-2 minutes until a connection is stablished.
    if you did everything correctly, it will work.
    So easy, fixed my problems just like that. Thanks!!

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •