i keep getting this error when i tried to restore
"The software required for communicating with the iPhone is not installed correctly"
so far its been happening on my laptop and desktop =/