Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Enabling 3G kills cell signal and disables internet

  1. #1
    Default Enabling 3G kills cell signal and disables internet
    My 3GS works fine on the Edge network. When I enable 3G, the cell signal drops to nothing for a about ten seconds and then it comes back to almost normal strength. The Edge network symbol disappears and there is no 3G to replace it.

    When I try and access the data network (not wifi) I get the "you are not connected to the internet" message. If I turn off the Enable 3G nothing happens, I do not get the Edge symbol back.

    Only way to fix this is to restart the iPhone and make sure 3G is not enabled.

    I am currently in Saudi Arabia and the phone worked fine in the States. Others out here are running 3G with no problem so I'm not sure what I'm doing wrong....

    I am thoroughly stumped. Any help would be greatly appreciated.

  2. #2

  3. #3
    Out here in Arabia I'm with Al Jawal which I believe is STC...

  4. #4
    iPhoneaholic sursture's Avatar
    Join Date
    May 2008
    Location
    US - the land of the fat
    Posts
    366
    Thanks
    4
    Thanked 98 Times in 88 Posts

    I would suggest to make clean restore - what you are describing is really weird abnormal behaviour.
    Make a note of what apps you have installed from Cydia/Ice - it is not too hard. Then just do the restore jailbreak n unlock - the chance is high that the problem is gone.

    A restore is defenitively yr best shot apart from exchanging the iPhone on warranty....but that could be difficult for u I guess
    Do hope that helps



    _________________________________________________

    **uoʇʇnq sʞuɐɥʇ ǝɥʇ ʇıɥ puɐ puıʞ ǝq noʎ pǝdןǝɥ sɐɥ ǝuoǝɯos ɟı**
    _________________________________________________




  5. #5
    Default Ok, I'll give it a try later today...
    I'm pretty technically challenged. Doing a restore sends shivers down my spine :0)

    Any chance that my sim card over here is not 3G capable or enabled? That still doesn't answer the not switching back to edge issue though.

    I've read the Dev-Teams blog on upgrading to 3.0.1 and I believe it was pretty much just as simple as doing the 3.0, correct? Any big fixes in the upgraded software?

    Just spoke to a guy who has the 3G out here on Al Jawal and he has been able to get 3G speeds from the get go. Here we go for the restore......

    Thank you for your help!

    --------------------------

    No luck... I upgraded to 3.0.1 via the Redsn0w Jailbreak and then unlocked the phone via Ultrasn0w and I'm still having the same issue on the internet connectivity shutting down when I enable 3G. Have to restart phone to get even Edge up and running again.

    Wow this is frustrating :0)
    Last edited by fullboat2; 2009-08-23 at 12:49 PM.

  6. #6
    Still no luck... although a new issue has cropped up, I am now able to access the cellular data network without putting in the APN which has always been necessary on the Al Jawal network. (jawalnet.com.sa)

    I'm starting to wonder if somehow some settings are still in play even after a restore. Not sure how that would be possible, but......

  7. #7
    Well, it turns out it was the sim card. I went into STC and they gave me a new sim. I'm good to go on 3G! So easy.... Ugh!

    Thanks for everyone who tried to help!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •