Page 1 of 2 12 LastLast
Results 1 to 20 of 26

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Mail, Contacts and Calendar disappeared from Settings

  1. #1
    Question Mail, Contacts and Calendar disappeared from Settings
    As the title says when i go to settings i don't have mail contacts and calendar. So basicly i can't copy numbers from my sim to my phone or i can't set my email optins. I have 2G on 3.0 and i am wondering if this problem can be fixed without restore. Could this be an option from some program, i have installed lockdown, categories, sbsettings, mysms, winterboard, icy and ibluetooth. Could some of this programs be the blame for my problem?
    PS: After i upgraded to 3.0 and jailbrocked and unlocked my phone thes settings where available but some time after that they where gone, i can't say when because i just noticed now. Any sygestions besides restore?
    Last edited by Scovik; 2009-08-19 at 08:32 PM.

  2. #2
    Livin the iPhone Life Simtech's Avatar
    Join Date
    Aug 2007
    Location
    LA
    Posts
    2,387
    Thanks
    105
    Thanked 304 Times in 276 Posts

    Uninstall Supreme Preferences.

  3. #3
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    I don't think you have any choice but to restore. From what you have told us it may be if have both Icy and Cydia installed. Not 100% sure that's what caused the problem you are having but there is a known conflict with having both installed. There could be another app that could be causing this also. Restore re-jailbreak and set up as new phone would be my advice.

  4. The Following User Says Thank You to Bo Troxell For This Useful Post:

    Simtech (2009-08-19)

  5. #4
    Livin the iPhone Life Simtech's Avatar
    Join Date
    Aug 2007
    Location
    LA
    Posts
    2,387
    Thanks
    105
    Thanked 304 Times in 276 Posts

    ^^^
    Oops, you right blkcadi, didn't see the part about cydia and icy.
    Restore...

  6. #5
    oaaaaa crap.........not really in the mood for restoring right now, but ty for your promp answer.....
    LE : any other options besides restore?
    Last edited by Scovik; 2009-08-19 at 09:29 PM.

  7. #6
    same issue here anyone know of a work around other then restore??

  8. #7
    What's Jailbreak?
    Join Date
    Jul 2009
    Location
    France: what a sh!t hole
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Sorry to drop in and all, but what issues can spring from having both cydia and icy installed ? I have had both for forever and not noticed any troubles; but what might I expect ?

  9. #8
    I had this problem recently and managed to solve it without a restore.

    It may seem simple but, do you have categories installed.
    If you have Mail in a category it will have automatically been hidden, along with the its section within settings.

    Even if you're not using categories this fix may help

    Open up SBsettings, go to more, then hide icons. if mail is set to off change it to on and see if your mail settings reappear. Worked for me.

    I still have to hide and unhide it when i want to go into the settings as it means the mail icon is visible outside of my categories but at least I don't have to restore

  10. #9
    Correct. Unhide mail.

    No restore needed.

  11. #10
    Default Uh Oh
    I looked in SBSettings and Mail was already unhidden. Is there any way I can get the settings for Mail back without starting over?

    Problem SOlved. I removed Extended Settings and my mail, calender settings reappeared.
    Last edited by jgkeegan; 2009-09-15 at 09:12 PM. Reason: Automerged Doublepost

  12. #11
    Default same problem
    i've got a same problem here, my mail button disappeared along with mail, calendar, contacts in settings. Pls tell me what you did. i 've got it jailborken too, so i don't wanna restore it

  13. #12
    Go to Cydia and uninstall extended SB settings. Your Mail and calendar will reappear

  14. #13
    Default I am newbie
    While i trying to delete that damn SB settings from cydia, i deleted something else and locked my phone. :P
    And got it unlocked by an expert. even though the setting is still not avail.
    BTW, I can't find SBSetting in my cydia, it's not there.

  15. #14
    had the same issue with the missing tab. restore and set up as new. i think it is something with icy and cydia being installed cause i had icy and then installed cydia as well.

  16. #15
    I guess so. Tnx for replying.
    after i got it restored and unlocked again, i'll let u know guys.
    Tnx

  17. #16
    Ok, so I'm having this same issue here, (except I'm using stacks and hiding the original icons). I'd like to have mail hidden from the springboard, but still have the settings show. This must be possible, since my iPod, and SMS icons are also hidden, but their settings do not dissappear.

    This seems to be an issue with SBsettings, and should be filed as a bug, but I have no idea where to report it.

    On another note, does anyone know where the plist files are located that control what shows in the settings app and on the springboard? I assume we might be able to solve this manually by editing some files and circumventing SBsettings.

  18. #17
    I've had the same problem with "Mail, Calendar and Contacts", "Safari" and "Store" settings disappearing from the settings app. Hiding the mail app or placing it in a "Catagories" folder would make the settings disappear. This time removing extended preferences solved the problem. There is a bigger problem here than just hiding an app. I'm using an iPod touch 2G with v3.1.2 and blackra1n. This only became an issue after I upgraded to v3.1.1 from v3.0.1 . Any help in this matter would be welcome.

  19. #18
    What's Jailbreak? AkkeDaBest's Avatar
    Join Date
    Feb 2010
    Location
    Finland
    Posts
    21
    Thanks
    6
    Thanked 1 Time in 1 Post
    Default The Solution is in winterboard!!!
    So I was having this same issue but I did a Trial and Error and finally after uninstalling and installing SBSettings, I went to SBSettings/More/Mobile Substrate Addons and de-activated all of them. That solved my problem, but I wanted to know what exactly was causing it. I enabled one at a time till the settings disappared again. It was WinterBoard. Then I went to WinterBoard and turned all off. That worked. And then I started enabling stuff untill the settings dissappared again. The exact thing causing this seems to have been OldDock. So disable OldDock and all the stuff in settings are back. OldDock is located at Winterboard/OldDock.
    Hope this helps you out!
    Thank me if it helps!!!

    ~AkkeDaBest

    Quick walktrough:

    1. Open winterboard
    2. Disable OldDock

  20. The Following User Says Thank You to AkkeDaBest For This Useful Post:

    asctony (2010-02-04)

  21. #19
    Quote Originally Posted by AkkeDaBest View Post
    It was WinterBoard. Then I went to WinterBoard and turned all off. That worked. And then I started enabling stuff untill the settings dissappared again. The exact thing causing this seems to have been OldDock. So disable OldDock and all the stuff in settings are back. OldDock is located at Winterboard/OldDock.
    Hope this helps you out!
    Thank me if it helps!!!

    ~AkkeDaBest

    Quick walktrough:

    1. Open winterboard
    2. Disable OldDock
    I disabled winterboard under SBSettings\More\Mobile Substrate Addons\and turned WinterBoard OFF. That worked, I can see Phone,Mail, Contacts, Calander, etc. However, then I do loose some of my WinterBoard options such as ABetter Tap to Unlock. When I go directly to WinterBoard via WinterBoard Icon, I do not see an option 'OldDock' to disable? I only see Volume Boost X3, Extended Preferences, A Better Tap to Unlock, Black Navigation Bars, Dim Icons, Dim Wallpaper, No Docked Icon Labels, No Undocked Icon Labels Solid Status Bar, Server Lock Example.Saurik, Transparent Dock, User Lock Background, User Wallpaper Volume Boost 3.0. Do I need to download something else? Thanks for you help. I did give you a Thank you!

  22. #20
    I just disabled Extended Preferences from WinterBoard and it just worked. give it a shoot

  23. The Following User Says Thank You to atenasjeb For This Useful Post:

    asctony (2010-02-27)

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •