I am still running OS 2.1 on my iphone 2g, as i dint really feel the need to upgrade to 3.0.

Wht i notice suddenly is that a lot of apps, which were working earlier, are now crashing to safe mode. Also a lot of new apps which i try to install crash to the safe mode.These are mostly new apps compatible with OS 3.0 .

What i would like to know is that ...is there a way in which i could run apps developed for 3.0 on 2.1, as i dont really feel the need to upgrade to 3.0 yet.