Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: my phone checks email whenever I get a call :mad:

  1. #1
    iPhoneaholic Rescuer's Avatar
    Join Date
    Mar 2008
    Location
    Bay Area, CA
    Posts
    419
    Thanks
    17
    Thanked 67 Times in 48 Posts

    Default my phone checks email whenever I get a call :mad:
    Whenever somebody calls me, my phone automatically checks my emails for some reason.

    I have fetch turned off. I have all 4 of my emails set to manual.

    Am I missing something?

    Thanks



    3GS
    purplera1n'd

  2. #2
    iPhoneaholic eatjello's Avatar
    Join Date
    Nov 2008
    Location
    Leesburg, Virginia
    Posts
    329
    Thanks
    9
    Thanked 56 Times in 41 Posts

    do you use any RockApp apps?

  3. The Following User Says Thank You to eatjello For This Useful Post:

    Rescuer (2009-07-29)

  4. #3
    iPhoneaholic Rescuer's Avatar
    Join Date
    Mar 2008
    Location
    Bay Area, CA
    Posts
    419
    Thanks
    17
    Thanked 67 Times in 48 Posts

    I did once and completely uninstalled it, as well as SSH'ing and deleting all the other directories/files it made.

    it was quickSMS or whatever.

  5. #4
    iPhoneaholic eatjello's Avatar
    Join Date
    Nov 2008
    Location
    Leesburg, Virginia
    Posts
    329
    Thanks
    9
    Thanked 56 Times in 41 Posts

    do you have SB settings? check under your processes and see if Mail.app is constantly running.
    Mine constantly runs because of RockApp, and when i respring or get a burst of data, my mail.app checks for mail, even when my stuff is on manual

    To fix it, go into settings, mail, Fetch new data, turn push off, Fetch to manual.

    Click advanced, and change the email accounts from Manual to Fetch.

    that will fix your problem, you should now find that you can end the process mail.app in sbsettings, where as you couldnt if they are set to manual instead of fetch under advanced.

    Hopes this helps
    Last edited by eatjello; 2009-07-28 at 11:16 PM. Reason: Automerged Doublepost

  6. The Following User Says Thank You to eatjello For This Useful Post:

    Rescuer (2009-07-29)

  7. #5
    iPhoneaholic Rescuer's Avatar
    Join Date
    Mar 2008
    Location
    Bay Area, CA
    Posts
    419
    Thanks
    17
    Thanked 67 Times in 48 Posts

    Thanks i followed exactly what you said.
    push off, fetch to manual, changed emails from manual to fetch.

    I'll have to wait a day to see if it's fixed for good

  8. #6
    iPhoneaholic eatjello's Avatar
    Join Date
    Nov 2008
    Location
    Leesburg, Virginia
    Posts
    329
    Thanks
    9
    Thanked 56 Times in 41 Posts

    You're welcome, all the best

  9. #7
    Mine does the same thing. It kinda defeats the purpose of push/fetch email to turn them off. Mine was set to check for mail once an hour, but it would also check each and every time I woke the phone up or answered a call whether it had been an hour or not. It's quite annoying when you answer a call then 20 seconds later the phone vibrates and dings. Whoever I am talking to can also hear this. Everyone ALWAYS asks "What the heck was that". That's also probably part of my crappy battery life if it is checking email every time i wake it up?? It also checks the email every time i open the email app, which defeats the "check once an hour" setting.

  10. #8
    iPhoneaholic Rescuer's Avatar
    Join Date
    Mar 2008
    Location
    Bay Area, CA
    Posts
    419
    Thanks
    17
    Thanked 67 Times in 48 Posts

    Quote Originally Posted by boozie View Post
    Mine does the same thing. It kinda defeats the purpose of push/fetch email to turn them off. Mine was set to check for mail once an hour, but it would also check each and every time I woke the phone up or answered a call whether it had been an hour or not. It's quite annoying when you answer a call then 20 seconds later the phone vibrates and dings. Whoever I am talking to can also hear this. Everyone ALWAYS asks "What the heck was that". That's also probably part of my crappy battery life if it is checking email every time i wake it up?? It also checks the email every time i open the email app, which defeats the "check once an hour" setting.
    yes! it's super annoying! I have the status notifier which dings every 30 seconds if i have an unread email, sms, etc.

    when i'd answer the phone, it would start dinging.

  11. #9
    iPhoneaholic Rescuer's Avatar
    Join Date
    Mar 2008
    Location
    Bay Area, CA
    Posts
    419
    Thanks
    17
    Thanked 67 Times in 48 Posts

    Allright, I'm still having this problem.

    When I run the mail app to check my mail, then close it, it continues to run in the background processes still. I do not have backgrounder installed at all.

    I do have supreme preferences though, and saw a setting under the mail section to "prevent auto-launch", and have tried switching it on.

    The problem still exists.

    And if i run safari, then close it, it also continues to run in the processes until i manually kill the app in the process manager.

    Any suggestions on why it keeps doing this?

    Thanks all

  12. #10
    I'm pretty sure that mail will always run in the background at least it has on mine. AS far as getting a call this does not make it fetch my email. I have one account on push and one fetch manual. Respringing does however fetch it but this does not bother me at all.

    My suggestion is a restore to new iphone and start from scratch without any rockapps. Although when i did have rockapps this did not happen either.

  13. #11
    Retired Moderator Cer0's Avatar
    Join Date
    Apr 2008
    Location
    MN/WI
    Posts
    14,099
    Thanks
    395
    Thanked 1,182 Times in 915 Posts

    I don't have any rockapps on my phone and never had also everything is set to manual and in sb settings the mail app is not in the list. I get the same thing. It is not super annoying but just as I put the thing to my ear to talk to someone it dings at me.

  14. #12
    Theme Creator
    Join Date
    Apr 2008
    Location
    In a state of confusion
    Posts
    1,170
    Thanks
    519
    Thanked 648 Times in 427 Posts

    Quote Originally Posted by Rescuer View Post
    Allright, I'm still having this problem.

    When I run the mail app to check my mail, then close it, it continues to run in the background processes still. I do not have backgrounder installed at all.

    I do have supreme preferences though, and saw a setting under the mail section to "prevent auto-launch", and have tried switching it on.

    The problem still exists.

    And if i run safari, then close it, it also continues to run in the processes until i manually kill the app in the process manager.

    Any suggestions on why it keeps doing this?

    Thanks all
    I have the same thing going on. I don't recall having ever had any Rock apps, but I too get the mail check issue as well as my ipod app always, and I mean always showing up in the Processes in SBSettings. Safari always seems to continue to show up as well, long after I have closed it, but I do not close each of the pages within the app, so i don't know if that makes a difference.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •