Hi ppl,

I have an iPhone 3G 8GB that wasjailbroken to 2.2.1 running yellowsn0w as i was using my UK Vodafone sim. Yesterday 5th Jul 09 i upgraded to 3.0 using Pwnage tool 3.0 to jailbreak for obvious reasons.

Worked fine and did it 1st time. Then went on Cydia and addes the repo666.ultrasn0w source to get ultrasn0w. Installed it and worked fine waited 1min and Voda popped up top left and was good to go.

Today the phone ran out of battery after a day and a half of use and was really happy with the improved battery life.

Just charging it now but it stays at 3/4 charged even though its been on charge most of the evening. like 2 hours or so. Have turned off all notifications and push settings but no luck.

Also i keep gettin the home buttons message pop up randomly like its a fresh install!

Another thing the icons keep re-arranging them selfs back to the standard 3.0 layout!

Any help or any fixes would be appreciated! Apart from that the phone is fine!! lol

Thanks in advance!

Dan. Manchester, UK