Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Bricked iPhone 3G after 3.0 upgrade

  1. #1
    Default Bricked iPhone 3G after 3.0 upgrade
    Hi everyone,

    title says it all but here are the details:

    - my iPhone was not jailbreak-ed. performing upgrade form genuine 2.2.1
    - after googling i tried to restore it via itunes doing the following:
    1) shut down the iPhone by pressing home + wake/sleep for ten seconds
    2) keep the home button pressed and attached the usb cable
    3) on the iPhone screen appears a message which tells me to connect the iPhone to the Mac (it's already connected)
    4) iTunes starts and tells me that it detected an iPhone in recovery mode and i press OK
    5) it warns me that it would erase all my personal data and blah blah and I press OK
    6) the restore process goes flawlessly until..
    7) it finally says that in order to complete the process it would restart the iPhone and tells me to keep it attached to the USB
    8) after that the iPhone keeps restarting again and again (apple logo for a minute, black screen for a while and the restart again)

    just for the record: i tried restoring to the 3.0, 2.2.1 and 2.2 firmwares. same stuff. i tried different OS too (leopard and vista)

    while attached, it tries to reboot over and over again, but if i unplug the USB cable it tells me to attach it back to itunes and asks me if i want to do an emergency call.

    if I attach it back the iPhone just freezes until I disconnect the cable again.

    reading the log file during the restore process it says that the process was successful but after the restart it hangs and keeps on restaring again and again, itunes cannot detect the device and it seems that is unable to activate the phone or something. while in this condition, if i disconnect the USB cable, the phone stops rebooting itself and shows a screen where it asks me to connect the phone to itunes in order ti activate it and gives me the option of doing an emergency call.

    there's gotta be something I still could do and i don't believe there's no way to entirely erase the phone and reinstall everything from scratch.

    please help me out

    thanks

  2. #2
    My iPhone is a Part of Me
    Join Date
    Feb 2009
    Location
    Central PA
    Posts
    521
    Thanks
    24
    Thanked 26 Times in 26 Posts

    lol, it's really not that hard to upgrade. I don't see how everyone is bricking their phone because of it.

  3. #3
    it is if your mac goes black-out right in the middle of the upgrade process

    i guess many people is complaining because the way how to restore the OS is not clear at all, and considering there's no way to read any kind of application log (besides itunes', which by the way says everything is ok) you can easily understand how people (including me) become puzzled and slighty angry.

  4. #4
    iPhone? More like MyPhone
    Join Date
    Aug 2008
    Location
    Perris CA, Diamond bar CA
    Posts
    177
    Thanks
    8
    Thanked 11 Times in 10 Posts

    Try to do a free restore with OS 3.0 then try to rejailbreak it

  5. #5
    thanks for your reply

    what do you mean by "free restore"?

    if you mean the standard restore procedure with itunes well. it's not working.

    more precisely: the process completes (itunes says that it will reboot the phone and to keep it plugged to USB) but after that the phone keeps resetting on and on, showing only the apple logo for few seconds and then goes blank.

    while in this condition, if i unplug the USB cable the phone shows the 'plug to itunes' screen with the option of making an emergency call.

    hope it helps

    i've got a small update:

    i change computer, network and operating system (now i'm trying to restore on windows xp sp3), i changed the usb cable and the result is that now doesn't start the restore process anymore!

    i've got the following message:

    An unknown error occurred (1604)

    well, at least i've got an error code..

    suggestions?

    thanks
    Last edited by valerio.donati; 2009-07-04 at 04:10 PM. Reason: Automerged Doublepost

  6. #6
    ok guys,

    I've managed to restore activate my phone. problem is: I don't know exactly how I did it, but basically this is it:

    1) put the phone in DFU mode and did the restore on another pc on another network (i used a friend's pc with Vista and iTunes 8.2)
    2) when iTunes finished the restore, it told that he'd have rebooted the phone and to keep it attached to the USB. after that the phone started rebooting itself on and on
    3) at this point i was about to toss the phone out of the window but instead i decided to give another try, which I haven't done before: I detached the USB connector from the PC and reattached it form another port. As you may guess, it worked: iTunes detected the phone and told me that it was successfully activated.

    Now, from this story i learned that if your phone is bricked and can't restore it you should:
    - try and restore it from another machine
    - try different USB cables
    - try different USB ports (also during the process)

    Thanks guys

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •