Results 1 to 18 of 18

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: apt-get not working in MobileTerminal

  1. #1
    Default apt-get not working in MobileTerminal
    hey there
    i m on OS 3.0 on my iPhone 3g.
    I have mobile terminal installed on my iPhone.
    But whenever i run these commands i get error.

    Code:
    apt-get update
    command not found error is generated. What should be the problem?

    32 views , no replies??

    nobody??
    Last edited by raziiq; 2009-06-25 at 02:02 AM. Reason: Automerged Doublepost
    iPhone 4
    Firmware : iOS4
    Carrier : Softbank (Japan)
    Jailbroken using Jailbreakme

  2. #2
    I've got the same problem; I'll post here if I figure it out.

    edit: I've found several other people with the problem, all with no replies. This has been since approx Aug of '08. I'm going to assume they disabled the function maybe? Oddly though, when you type help, it's no in the list with a * (it says * denotes disabled). So.....hm.
    Last edited by alyehoud; 2009-06-25 at 03:49 PM.

  3. #3
    thanks for the reply man.

    Well i also didnt have apt-get in my Mac Terminal, so i installed fink from some site and now apt-get is available in my Mac Terminal, i think there should be the same trick for MobileTerminal as well. I think the definition of apt-get is not installed in the PATH variable.
    iPhone 4
    Firmware : iOS4
    Carrier : Softbank (Japan)
    Jailbroken using Jailbreakme

  4. #4
    What's Jailbreak?
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    21
    Thanks
    6
    Thanked 1 Time in 1 Post
    I have iphone 3g 0n 3.0. My mobile terminal crashed on start up. How did you install on 3.0. Thanks

  5. #5
    No special trick, just installed it the way it should be installed, but one problem i m having is that its up side down and then i have to do 2 finger gesture to make it to original
    iPhone 4
    Firmware : iOS4
    Carrier : Softbank (Japan)
    Jailbroken using Jailbreakme

  6. #6
    Raz, for that upside down part I can help - just tilt it like you want to angle towards you, and it will flip. You can go sideways too, but it's more difficult to read, in my opinion.

  7. #7
    Thanks man, that tilt thing helped ,
    iPhone 4
    Firmware : iOS4
    Carrier : Softbank (Japan)
    Jailbroken using Jailbreakme

  8. #8

  9. #9
    nobody aware of that apt-get problem??
    iPhone 4
    Firmware : iOS4
    Carrier : Softbank (Japan)
    Jailbroken using Jailbreakme

  10. #10
    waoo i have got it !!!.
    thank GOD at last, i have got it.

    Well someone else looking for this here is the solution if u are having an unknow command error while using apt.

    Firmware 3.0 doesnt have this installed by default when u jailbreak it, so u need to install Aptitude from Cydia, and then if u use apt-get command in Terminal, BOOM, it ll work !!!
    iPhone 4
    Firmware : iOS4
    Carrier : Softbank (Japan)
    Jailbroken using Jailbreakme

  11. The Following User Says Thank You to raziiq For This Useful Post:

    sid_iPhone` (2009-06-30)

  12. #11
    I have installed aptitude and terminal, I am using 3.0 on a 3G, but it still comes up with the error: apt-get command not found. :S

  13. #12
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    Quote Originally Posted by gliitch View Post
    I have installed aptitude and terminal, I am using 3.0 on a 3G, but it still comes up with the error: apt-get command not found. :S

    same here

  14. #13
    Oh i managed to get it to work in the end,Just rebooted it, then it started working for some weird reason :S Ah well ^_^

  15. #14
    Installing Aptitude and Erica Utilities worked perfectly for me on OS 3.0, and I could run the apt-get command in Mobile Terminal successfully...

  16. #15
    Default fix it
    even if this thread a bit old
    i also had this problem
    you have to install the APT0.7Strict console package (with this little console sign beside the icon)
    be sure that you have set the package settings to developer mode
    important commands:
    Code:
    apt-get update
    apt-get upgrade
    apt-get autoremove (removes packages that you dont use anymore)

  17. The Following User Says Thank You to breadnbutter For This Useful Post:

    zikamur (2010-05-23)

  18. #16
    Many Thanks !
    This fixed issue
    By installing "APT0.7Strict console package (with this little console sign beside the icon)" (get it in developer mode), i know have apt-get commands

  19. #17
    i had the same problem but i managed to fix it, download the aptitude from cydia and reboot or download issh from the appstore or elsewhere then try it again, you may get a problem saying that a file cannot be accessed, use file to get to the file and change access permissions to all of them and try that

  20. #18
    Quote Originally Posted by zikamur View Post
    Many Thanks !
    This fixed issue
    By installing "APT0.7Strict console package (with this little console sign beside the icon)" (get it in developer mode), i know have apt-get commands
    You also get them when you install cydelete (which in and of itself is pretty handy).

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •