View Poll Results: What firmware should I go with when jail breaking?

Voters
9. You may not vote on this poll
  • iPhone 2.2.1

    7 77.78%
  • iPhone 3.0 beta (newest version what ever it is)

    2 22.22%
Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Should I go with iPhone 3.0 or 2.2.1?? NOOB

  1. #1
    Default Should I go with iPhone 3.0 or 2.2.1?? NOOB
    I am switching from verizon to att and getting the iphone 3G tonight. I am going to use my iphone for mostly applications and not so much music.

    Should I update and jailbreak my iphone with 2.2.1 or the new 3.0 beta?

  2. #2
    Livin the iPhone Life seann33uk's Avatar
    Join Date
    Jan 2008
    Location
    Some where in the milkyway
    Posts
    1,314
    Thanks
    13
    Thanked 127 Times in 115 Posts

    never use a beta on something important like a phone.

    you dont want it fricking up when you're in middle of nowhere
    Being an i can be a lot of pressure. you have to live right up to the small point.

  3. #3
    If you want all your apps compatible...then 2.2.1

  4. #4
    Retired Moderator Zwayne's Avatar
    Join Date
    Nov 2007
    Location
    Independence, LA
    Posts
    5,633
    Thanks
    656
    Thanked 764 Times in 591 Posts

    Quote Originally Posted by cpjr View Post
    If you want all your apps compatible...then 2.2.1
    ^+1

  5. #5
    iPhone? More like MyPhone babydol's Avatar
    Join Date
    Dec 2008
    Location
    Oklahoma
    Posts
    130
    Thanks
    5
    Thanked 2 Times in 2 Posts

    stick with 2.2.1......especially if you're just getting an iphone

  6. #6
    2.2.1

    ive used beta 1 & 2 and both of them turn the iphone into a buggy, unreliable device. you can expect 2-3 restarts a day. stay on 2.2.1

  7. #7
    My iPhone is a Part of Me
    Join Date
    Feb 2009
    Location
    Central PA
    Posts
    521
    Thanks
    24
    Thanked 26 Times in 26 Posts

    2.2.1 if you're a n00b

  8. #8
    My iPhone is a Part of Me IvanPK's Avatar
    Join Date
    Apr 2008
    Location
    USA
    Posts
    611
    Thanks
    56
    Thanked 47 Times in 44 Posts

    2.2.1 since it's your first iPhone. When the thing is your phone, you have to make sure it's reliable.

  9. #9
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    Where is 2.2 as an option??? That is MY RECOMMENDATION.

    Especially as a NOOB..... use 2.2 and WinPwn. Will work fine with AT&T. But also.... it will work with other carriers IF you want to change.

    If you go 2.2.1 (and don't use a Mac w/Pwnage) or never-use-a-beta 3.0; you'll be STUCK with AT&T - maybe forever

    Personally, I prefer more options. The difference between 2.2.1 and 2.2 is very very small. JB'ing 2.2 is is solid, easy, and well-tested.

  10. #10
    iPhone? More like MyPhone Sadhunni's Avatar
    Join Date
    Jan 2009
    Location
    New York
    Posts
    231
    Thanks
    2
    Thanked 8 Times in 7 Posts

    I recommended 2.2.1 because of games and application. 3.0 freezes a lot and I dont think you want it

  11. #11
    2.2.1, the beta isnt for real use! Its just for developing apps or screwing around. If you have two phones or you dont value your precious iphone you can go beta. but i wouldn't in ur shoes.

    Also y didnt u wait like 1 month till iphone 3.o (the new hardware came out?)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •