Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Call failed unless headphone is plugged in

  1. #1
    Question Call failed unless headphone is plugged in
    Hey guys,

    I would like to share a problem I've encountered. I can't make calls without using the headset. Whenever I unplugged the headset there will be no signal during a call. Initially the signal is full and without the headset the call cannot be done because it will display "call failed". I'm only able to sms without headphones.

    So currently calls can only be made or received if i have headphone plugged in or else it would display call failed although I've full signal. Sms is working well.

    Below are the details of my phone:
    Iphone 3g 16gb (US version)
    firmware 2.2.1
    baseband 2.30.03
    unlock sim: rebel sim (x-sim v61) worked all the time till this happened
    always had 3g disabled and data roaming enabled to ensure my signal is there
    tried solving using the methods like inserting my sim into other phones to select network then insert back into the iphone and it couldnt fix this problem.
    jailbroke using quickpwn 2.2.5

    I know having fw 2.2.1 and baseband 2.30.03 sucks but any experiences in solving this problem is appreciated.

    I've tried having to select "loudspeaker" ASAP before call failed pops out when making calls without headset and it works. but whenever I disable the loudspeaker to go back to using the normal stuff it fails. Is it the speaker on top of the phone which is broken? Also tried restoring again and rejailbreak it to test the results and its the same. Downgraded the firmware to test the difference and its the same too.

    Is it hardware failure? (receiver or headphone jack problems)

    Any suggestions to fix this problem?

  2. #2
    I've had the same problem and had mine replaced twice!
    Contact O2.

  3. #3
    Wow! I just figured out my phone has the same problem!
    Anyone find out a fix to this?

    Wow! I just figured out my phone has the same problem!
    Anyone find out a fix to this?
    Last edited by ho99ss; 2009-05-04 at 11:05 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •