Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Iphone keeps connecting then disconnecting?

  1. #1
    Default Iphone keeps connecting then disconnecting?
    I got a new laptop this week, and installed XP on it. well today i tried to connect my iPhone 3g to it, and it connects for less than 2 seconds then disconnects. It just repeats over and over. I know it isn't the iPhone or the cable, because it still connects fine to my Desktop computer.

    The laptop is a Compaq CQ60-210US. All my other USB stuff works(Mouse, Jump Drives, camera, etc...). Has anyone had this problem? or knows what i can try to fix it? Please let me know.
    Thanks, Jared

  2. #2
    Never heard of this one before. Sorry I can't help you. Just wanted to say... That must be sooooo annoying

  3. #3
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    TX  Follow me @StealthBravo
    Thanked 5,329 Times in 3,113 Posts

    I would try plugging in a usb hub and trying it. you never know

  4. #4
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    In a van down by the river
    Thanked 515 Times in 427 Posts

    Maybe something installed wrong with your phone drivers. If other periphreals are working in the USB slots that is where I would look first.

    Read this: Apple - Support - Discussions - iphone keeps disconnecting and ...

  5. #5
    Same thing used to happen to me on my desktop but with the first gen iPhone... I just plugged it into a different usb port in the back and it stopped...

  6. #6
    I have tried all the ports on the laptop but none are working. And like captainchoas said i am pretty sure that the drivers did not install correctly. is there any way to install the drivers from a file rather then the phone?

  7. #7
    What's Jailbreak?
    Join Date
    Nov 2007
    Vancouver, BC
    Thanked 3 Times in 3 Posts

    You do have iTunes installed?

  8. #8
    Quote Originally Posted by Steen View Post
    You do have iTunes installed?
    What is iTunes???

    Of course i have itunes installed!!!!

  9. #9
    My iPhone is a Part of Me lach's Avatar
    Join Date
    Jan 2009
    Thanked 82 Times in 67 Posts

    i had a similar problem, i removed iTunes from my computer, the on my iPhone 3G i reset all content and settings, then reinstalled iTunes and connected my iPhone to the computer and it worked. I am also using vista. I have no idea how it fixed it but thought id let you know anyway!

  10. #10
    Default Deja-Vu
    Dude, I have the EXACT same problem as you and its pretty annoying, my laptops a Compaq Presario CQ60 and every 2 seconds it connects then disconnects, then it connects for 5 seconds then goes back to doing its 2 second thing. I think/hope using a USB hub will work? I have no idea how affective the other ways are though.

  11. #11
    I've just installed a new Shuttle XPC SX58J (LGA1366 motherboard with W7 x64)... experienced the same issue, USB keeps rejecting connection. Reinstalled Apple Mobile Device driver, no good. Checked the USB hub drivers... they were installed from the Shuttle driver DVD, Intel chipset but certified by Microsoft, reinstalled, no good.

    Googled for more information and went to Intel site and downloaded the latest chipset drivers... installed, rebooted, sorted!

  12. #12
    Thumbs up Hope it will solve the problem... dont ask me I too late replied :)
    Dear all I found its solution, I was too much tired and wasted approx 2 days with installing fresh windows 7 64bits for four times as there was same problem and it was disconnecting and reconnecting within seconds

    Actually there was problem with incorrect iPhone data cable, if you are not using original cable which came with iPhone then it will work for you too, because there is available iPhone cables in market those are not compatible with iPhone 4 or 4S, I had data cable and there were 4 pins inside of 30 pins connector and when I connected 5 pins inside of 30 pins connector my iPhone is working perfect

    Correct pins configuration is hereunder


    Hope it will work for you


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts