Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iphone 3G gave up on me...! Will not restore! HELP....!

  1. #1
    Smile iphone 3G gave up on me...! Will not restore! HELP....!
    Hello everyone,

    I bought a water damaged(what the hell was I thinking??) iphone 3G off craigslist, with everything working except for the camera. I replaced the camera module myself. During replacing process, I did notice visible water stains at the bottom half of the phone. A few pins of connector cable # 4 were rusty due to water residue. I cleaned'em, and performed a thorough visual inspection of the logic board itself. I found two or three tiny resistors at various locations on the board with green rust like stuff accumulated around them!

    The data connector flex cable module enclosure also seemed to have taken a hit due to water, but I did not bother opening it and inspecting, as phone was functional.

    I cleaned everything and reassembled the phone. After that I used the phone for four months without any problem. Everything worked perfectly, including camera!

    Two days ago in the morning, as part of my daily routine, I plugged a fully functional iphone to the usb port of my PC laptop and turned the laptop on, so that the phone gets fully charged, by the time I get get ready for the office. Charging screen appeared with 90% or so charge in it and I left the room.

    After a few minutes,I incidentally saw the phone rebooting itself with white apple logo. While still connected to the pc, I waited for a while for it to restart, but it never did and turned itself off after a while. After that, it never turned on when it was not connected with a power supply.

    I then resorted to restore its firmware using itunes 8.0, 8.1, 7.7 and on two pcs by installing fresh windows xp and then fresh itunes!..I know this whole effort is a pain.... I used all the firmwares out there, in both recovery and DFU modes, but was never able to restore any firmware.

    Almost every time, I encountered the following typical sequence of events;

    When I connect the iphone to PC itunes,

    1) Phone would turn itself on showing apply white logo and then goes to recovery mode with typical "connect to iTunes logo" screen. iTunes would recognize it and ask to restore it with latest firmware. When I select either restore for the latest firmware or shift restore for an older firmware (e.g. 2.2, 2.1, 2.0.1, 2.0.2), itunes would extract the firmware software and then would immediately show an error "iphone "iphone" could not be restored. An unknown error occurred (23).

    When I put iphone in DFU mode (switch off, press power button for 5 seconds, power and home button for 10 seconds, release power button but keep holding home button till itunes recognizes it in DFU mode and the phone display stays blank)

    At restore attempt, all of the above happens except for one difference, after itunes extracts the software, iphone display changes to bright white and itunes shows "preparing iphone for restore", after a while iphone disconnects and restarts with white apple logo and then turns off.

    First I thought its a software issue, but after trying all the above, I suspect it to be a hardware one. Either Logic board finally gave way, due to above mentioned tiny resistors having been impacted by water, i guess? OR, data connector flex cable, which seems to carry circuitry of it's own finally got corrupted, due to water damage?

    So what should I do? Should I replace the data flex cable to see if the phone comes to life.

    OR, am I way out of line, and it still is a software issue?

    Any help from any of tech gurus is greatly appreciated.

    Thanks,

    manz73

  2. #2
    I found this
    Don't know if it will help but possibly worth a try?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  3. #3
    Unhappy Iphone 3G will not restore
    Hi confucious,

    Thanks for the post. None of the suggested remedies from your link worked in my case. But thanks for the link.

    I have installed SSH, which used to run at start up automatically. But since the phone would not boot, not even turn on unless connected with data cable, I guess, I would not be able to SSH into the phone using iTunnel etc to delete any unwanted files like mobileinstallation.

    I tried Winpwn 2.5 as well. It recognizes phone in dfu mode, but then immidiately disconnects the phone with an error message, which sort of says unsupported iTunesMobileInstallation.dll found.

    I have odered the data connector flex cable. But I suspect the logic board is fried . I only hope that I am wrong.

    Can somebody guide me how to SSH into an iphone which is not booted into its firmware, instead is either in recovery mode or DFU mode?

    Thanks.

  4. #4
    I don't know if diskaid would connect? Might be worth trying.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  5. #5
    Diskaid would not recognize the iphone both in recovery and DFU mode. Hope is diminishing. Dunno if changing data connector flex cable would do any good or not.

    If logic board is blown, shouldn't it be completely dead?

  6. #6
    Are you using an original cable? If not then try one.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  7. #7
    I am using an iphone original external data cable (white color) with the phone which worked seamlessly for 4 months.
    I am thinking about changing the "internal data connector flex ribbon cable" which connects the external data cable with iphone 3G logicboard.

    The reason is that I think that internal data connector flex ribbon cable circuit (with tiny resistors) is blown due to water damage.

    I showed it to a mechanic who by very cursory inspection, told me that it's logic board is fried!

    If I could be sure of a software which allow user to access the internal file system in DFU or recovery mode, I atleast would be able to retrieve my data.

    thanks confucious for your guidance so far.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •