Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: I can't SSH

  1. #1
    Default I can't SSH
    I've been using Cycorder and I want to get my videos off my phone but I can't figure out how to SSH into the phone.

    I followed the guide here on this website but trying to install "Demon Apple FileSharing" it tells me "ERROR: URL using bad/illegal format or missing URL", so I can't do it that way. I've looked at other tutorials around the web, but certain repositories and apps no longer exist so i'm hitting dead ends all over the place.

    Is there an easy to follow UP TO DATE tutorial out there anywhere with directions that actually still work? I've tried 3 or 4 different ways and get no where.


    - Mark

    Last edited by markinhifi; 2008-09-15 at 07:11 PM. Reason: Automerged Doublepost

  2. #2
    Install Openssh from Cydia on the phone, Connect to a Wifi connection that your computer is also connected to, look in settings/wifi on your phone and get the ip address by touching the blue arrow icon.

    Install Cyberduck from Cyberduck | FTP, SFTP, WebDAV & Amazon S3 Browser for Mac OS X.
    setup a new SFTP (SSH Secure File Transfer) connection using the ip address from your phone and username:root password:alpine

    If you dont have access to Wifi follow this guide

    [Guide] SSH Without WiFi - ZodTTD: Home Of Homebrew

  3. The Following User Says Thank You to zendj For This Useful Post:

    markinhifi (2008-09-16)

  4. #3
    When trying to connect with Cyberduck it says

    I/O Error: Connection failed
    The kexTimeout (30000 ms) expired

    I tried it with another app (Transmit) and it says "Permission Denied"

  5. #4
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    In a van down by the river
    Thanked 515 Times in 427 Posts

    I use iPhone Tunnel Suite 2.7b. I am on a windows machine though. If there is a Mac version then you can connect like I did here:

  6. The Following User Says Thank You to CaptainChaos For This Useful Post:

    markinhifi (2008-09-16)

  7. #5
    I just got it working. SSH was turned off in BossPrefs. I didn't realize it created a little switch in there when I installed it. All is good now!

    Thanks folks.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts