Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 1.1.3 Bluetooth connection with carkit and headset problem FIX found...

  1. #1
    Default 1.1.3 Bluetooth connection with carkit and headset problem FIX found...
    Story..

    I bought a brand new 16GB iPhone, downgraded, upgraded back to dev 1.1.3 and unlocked. So cool.. Spent the whole night on saturday, without sleep to unlock it..

    Thought I have the coolest phone ever, until today, on the way going to school, I was talking to my gf on the phone via my car bluetooth, after about 1min, the connection lost.. Restarted the iphone and repair, hope to fix the problem, but did not.. So mad.. I spent the whole 3 hours in class surfing on my iphone hope to find a fix.. some said have to restore and choose "New iPhone", duh, my iPhone is brand new from the store, why would I do that stupid restore for.. others said to reset the networking, and airplane mod..., I did that, and still didnt fix the issue. I was thinking "hey, I maybe I could copy those bluetooth files and folders from a 1.1.2 iPhone to my 1.1.3, and it could work.." Ran home, pull out my old 8GB iPhone, which I did a fresh restore, and unlocked, now staying at 1.1.2. So I got home at around 9:30pm, jump into my computer, and started SSHing my iPhone.. After many tries of copying different files from 1.1.2 to 1.1.3, I failed and the iPhone still couldn't connect to the carkit bluetooth.. I decided to copy all the files and folders that has the word "bluetooth" in its title from my 1.1.2 to my 1.1.3, and voila it worked for the whole 15 mins of testing, didnt bail out on me.. So I will continue to test it for tomorrow and let everyone knows if it really works.. Then, I will post the Zip file of all the 1.1.2 fresh bluetooth files and the instruction where should it go on the 1.1.3...

    To Be Continued...

    --------------------------------------------------UPDATE------------------------------------------------

    Download Zip file here, you will need to extract the zip package:

    1.1.2_Bluetooth_Control_Files

    —————————–How to install—————————-

    Make sure that your iphone is jailbroken and has BSD Subsystem + OpenSSH installed.

    A) SSH into your phone using WinSCP or any other program that let you login into your phone directories..

    B) Back up and Copy the files: (make sure that you back up the original files or folders on your 1.1.3 iphone prior to copy.)

    1. Back up, then Copy/replace the whole “bluetool” folder into “/private/etc” folder

    2. Back up, then Copy/replace the whole “BluetoothManager.framework” and “MobileBluetooth.framework” folders into “/System/Library/Frameworks” folder

    3. Back up, then Copy/replace the whole “BluetoothSettings.bundle” folder into “/System/Library/PreferenceBundles” folder

    4. This is a little bit tricky. Look at the folder “sbin” you see my note say that “DO NOT REPLACE THE FOLDER” that means do not replace the “sbin” folder in the iPhone with this one. Only copy the files inside the “sbin” folder ONLY. So you need to double-click on the folder “sbin-do not replace the folder” folder to see the files. Now proceed to copy them onto the iPhone:

    Back up, then Copy/replace the files “BlueTool” and “BTServer” inside the sbin folder in my Zip package to the iphone “/usr/sbin”

    5. Back up, then Copy/replace the file “com.apple.BTServer.plist” into “/private/var/mobile/Library/Preferences”

    6. Restart the iPhone. And test it. It will hold the connection now
    Last edited by istorm; 2008-02-14 at 10:41 AM.

  2. The Following 3 Users Say Thank You to istorm For This Useful Post:

    kingkong (2008-02-22), rlopez97 (2008-05-20), Rustynuts (2008-02-13)

  3. #2
    iPhoneaholic
    Join Date
    Dec 2007
    Location
    West Yorkshire UK
    Posts
    459
    Thanks
    28
    Thanked 27 Times in 26 Posts

    sweet keep us posted, iv just upgraded too 1.1.3 and still waiting for my bluetooth headset too arrive, i would be pissed if it didnt work right..

  4. #3
    I seem to be having a similar problem, but it gets more complicated. Not only does the connection drop between my jailbroken 1.1.3 and my Parrot CK 3100 during some calls. But when I walk away far enough from my truck after a connection and it disconnects due to proximity, it locks my phone to a black screen and I have to rest the phone.

    Anyone else have this issue?? Feedback is appreciated. Thanks istorm!

  5. #4
    Bro, if this works & you post the zip, I'd be super stoked with you. I'd be happy to host it on my rapidshare account if you want a permanent link, even. I love having a jailbroken iPhone, but I use a bluetooth headset @ work & while playing video games, and my car as bluetooth. It's so annoying not having it work correctly that I'm strongly considering going to a standard 1.1.3. Especially since cradling the phone on your shoulder is essentially useless because of the form-factor and because of the stupid fact you can't lock the screen while your talking - essentially guaranteeing that you're gonna hit speaker or hold sometime in the conversation.

    Ethan

  6. #5
    Quote Originally Posted by WGray225 View Post
    I seem to be having a similar problem, but it gets more complicated. Not only does the connection drop between my jailbroken 1.1.3 and my Parrot CK 3100 during some calls. But when I walk away far enough from my truck after a connection and it disconnects due to proximity, it locks my phone to a black screen and I have to rest the phone.

    Anyone else have this issue?? Feedback is appreciated. Thanks istorm!
    Humm, that sounds strange, I never experience that problem b4. Anyway, I did a test today to see if my iphone with 1.1.2 files do anything like that. Well, nothing happen at all.. all went well. I left my car on, walked away until the phone disconnected with the car bluetooth, still normal, nothing strange happen. I walked back to the car and it automatically connected..


    After the whole morning testing calling, turn off, turn on.. blah blah... the bluetooth connection stayed intact.. YAY! No more disconnected, unless you want it to..

    I guess I will post the files tonite. Im at work right now and go to school after that.. so, everyone please be patient..

    Updated with zip package files
    Last edited by istorm; 2008-02-14 at 11:54 AM. Reason: Automerged Doublepost

  7. #6
    Quote Originally Posted by WGray225 View Post
    I seem to be having a similar problem, but it gets more complicated. Not only does the connection drop between my jailbroken 1.1.3 and my Parrot CK 3100 during some calls. But when I walk away far enough from my truck after a connection and it disconnects due to proximity, it locks my phone to a black screen and I have to rest the phone.

    Anyone else have this issue?? Feedback is appreciated. Thanks istorm!
    I have exactly the same problem with my Alpine car kit.
    It took me a while to figure out why my iPhone kept switching off, but now I've unpaired it, it hasn't happened since.

    I might try this 'fix' tomorrow and see if it works for me!

  8. #7
    I have the opposite problem. The phone pairs and works fine with my car but its after I turned my car off that it still thinks its connected.
    With 1.1.2 as soon as I turn my car off it would disconnect. Now with 1.1.3 it thinks it's still connected.

    I hate 1.1.3. Nothing good has come of it. Bluetooth doesn't work, constant freezing, no custom ringtones and noticeably degraded battery life due to things like open ssh turning back on after a restart.

    But I will try this anyways. Hope it works. lol

  9. #8
    Yeah guys, try it and let me know if this will fix all your problem. Technically it should because it use 1.1.2 bluetooth control files.

    Remember to backup your 1.1.3 bluetooth files.. I have already backed up mine, if you guys want I can publish it!

  10. #9
    Quote Originally Posted by ABT4 View Post
    I have the opposite problem. The phone pairs and works fine with my car but its after I turned my car off that it still thinks its connected.
    With 1.1.2 as soon as I turn my car off it would disconnect. Now with 1.1.3 it thinks it's still connected.

    I hate 1.1.3. Nothing good has come of it. Bluetooth doesn't work, constant freezing, no custom ringtones and noticeably degraded battery life due to things like open ssh turning back on after a restart.

    But I will try this anyways. Hope it works. lol
    Mine was doing this for the 1st week of 1.1.3 and now its switching itself off! I still havent tried swapping files as I couldn't get on this site all day. I'm now on my iPhone - but hopefully I can try tomorrow.
    I agree with the battery life being dreadful... I'm tempted to go back to 1.1.1!

  11. #10
    Livin the iPhone Life sziklassy's Avatar
    Join Date
    Jan 2008
    Location
    Iowa (ISU for Vet School!)
    Posts
    3,920
    Thanks
    69
    Thanked 310 Times in 264 Posts

    I had this probelm as well. A restore fixed it. Seems there are some issues with the old method. Restore and use ZiPhone... have not had a single issue with ANYTHING using ZiPhone.
    ------------------------------------------------------------------------------------------------------------------------------------------------------------------
    I once prayed to God for an iPhone, but quickly found out He didn't work that way...so I stole an iPhone and prayed for His forgiveness.

    A dog is the only thing on earth that loves you more than you love yourself. - Josh Billings

  12. #11

  13. #12
    So I just plug into iTunes and do a regular 1.1.3 restore, then run ziphone?

  14. #13
    I tried the restore 1.1.3 option and bluetooth was better but not 100% as in 1.1.2. So i am giving this a try only noticed three files of different size will test this and let you know results(hope this works)

  15. #14
    This fix by istorm worked for me 100%!!! not sure what 1.1.3 is getting ready for by changing the bluetooth files, but this did fix problems! thankyou!

  16. #15
    I did a restore to 1.1.3 in iTunes and then did Ziphone to jailbreak/activate/unlock.
    It seemed to work ok for a few days, but now I'm having the same problems again! The bluetooth still says its conencted even though I'm miles away from the car... and about 50% of the time the phone switches off after disconnecting!

    Like kingkong - the restore has made it a bit better, but not good enough!
    Looks like I'll be installing the 1.1.2 files when I get home!

    Hopefully this is something 1.1.4 will fix.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •