Results 1 to 16 of 16

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: 2.0.2 Root Password

  1. #1
    Default 2.0.2 Root Password
    Does anyone know if the root password has been changed in firmware 2.0.2? I repwned my iPhone today with the Pwnage tool and root and alpine will not work. Mobile and alpine will work, but I need to be logged in as root. I tried connecting over afp using the Netatalk package with no luck. I also tried to ssh with Fugu but it wouldn't even connect. It threw back to me that the host had been changed. I know I have OpenSSH installed on my iPhone.

  2. #2
    Renew your tcp ip address and make sure that your iphone can connect to your wireless network. Then open up your ftp program and make sure its at sftp with root and alpine. Sometimes you may have to install boss prefs to ensure that the SSH option is on and not accidently put to off.

  3. #3
    Retired Moderator Zwayne's Avatar
    Join Date
    Nov 2007
    Independence, LA
    Thanked 764 Times in 591 Posts

    And sometimes it takes a few times for it to work root & alpine.

  4. #4
    Default No really, something is up here.
    Just did a fresh PWNAGE tool restore on a ist gen iphone. . .

    Mobile/alpine works fine


    all fail. Bad passwords. Tried each one a dozen times, even did the reboot/resprint/tug on the USB cable/etc stuff. I can connect fine through finder on a macbook with the iphone having netatalk on it, but only as mobile.

    I can copy files to and from the iphone via finder no problem, but when I take, say, the sms.db from the iphone to the macbook it comes through fine, but if I try to put it BACK to the iphone, the permissions are set to mobile/rw everyone else/no access.

    Yes, this means I kinda screwed up my SMS abilities for the time being. Sigh.

    The point is, there is a new root password for some iphone users root accounts if they are on 2.01 or 2.02 with PWNAGE tool restores. Either this is a firmware thing from apple or something from PWNAGE tool.

    And no, I swear to whatever dieties you worship, and to the Gods of Mountain Dew if that works better for you, I did NOT CHANGE MY ROOT PASSWORD. This is a fresh restore, and root is no longer alpine or dottie.

  5. #5
    Just did a clean restore to 2.0.2 and used the newest QuickPwn. After installing cydia i installed SHH. I can not ssh in with alpine or dottie either.

  6. #6
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Thanked 27 Times in 25 Posts

    works fine for me with alpine i used quickpwn

  7. #7
    quickpwn my 3G phone to 2.0.1 and again to 2.0.2 and root/alpine works as expected ssh/sftp.


  8. #8
    Default Nope, not a password change, something else.
    Ok, here is what I did. It still does not work.

    1st gen iPhone
    PWNAGE tool 2.0.3 and installed firmware 2.0.2

    Used netatalk to get into the file structure from my macbook over a USB connection.

    Logged in with mobile as the user and alpine as the password. Worked fine.

    Tried to log in as root with all capitalization variants of dottie and alpine at least three times each. No luck.


    I then fired up Terminal on the iPhone, and typed in: su -

    It asked me for a password, I typed in: alpine

    Voila! I had root access. But only in terminal. If I try to log in via netatalk again with the exact same password, it says it's the wrong password.

    This is where my abilities come crashing to a halt. apline is the root password for my iphone if I use terminal, and it is not if I use netatalk. I have no idea what the next step is.

    private/var/stash/share has a netatalk directory, with permissions set at 0644 and icommander shows various root:wheel options. I don't have time to get to it tonight, but MAYBE changing the permissions so netatalk has root access is the direction to go. If anyone tries it, please let the rest of us know if it works.
    Last edited by davethegreat; 2008-08-30 at 08:25 AM. Reason: Automerged Doublepost

  9. #9
    I have figured it out!

    What has happened is the RSA key was changed for the iPhone when I pwned it the second time, so my Macbook couldn't recognize it anymore. I figured this out when I tried to ssh through the Terminal. What I did to fix it was delete my "known_hosts" file via the Terminal. I went to the Terminal and typed in "cd /Users/your user name here/.ssh. I typed in "rm known_hosts" to delete the file. Once that was done, I tried to ssh back into to my iPhone via Terminal. It sent back to me that my iPhone wasn't secure and asked if I still wanted to connect to it. I typed in yes, then my password and I got in! I can now use Fugu to get into my iPhone file system. I haven't figured out Netatalk yet, but it could be something close. I have one warning though. The "known_hosts" file contains info on all servers you have used ssh to get into. If you have other computers you have used ssh to get into, their information will also be deleted when you delete your "known_hosts" file.

  10. The Following User Says Thank You to octoarmor For This Useful Post:

    maclanz (2008-08-31)

  11. #10
    I'm having the same problem. When I try to use your solution, it looks as if the path was wrong, (...and typed in "cd /Users/your user name here/.ssh. I typed in "rm known_hosts"...)
    But I guess I'm just in the wrong directory and I'm not getting it. With cyberduck I couldn't find any "known_hosts"-file either. What am I missing?

  12. #11
    Default I don't have that director. At all.
    I typed in cd /Users/ in terminal and just don't have that directory. I tried it both as root and as mobile. The closest I could find is the usr directory, which has no subdirectory named any usernames that I can find.

    Also, if I did have that directory, what username would I use? I never felt the need to set up a username when I pwned the phone, so, root? Admin? Mobile? What default username would be there?

    Even tried a unix find command for the whole system, and came up with nothing named known_hosts. . . .

    Maybe there is a way to set these tasks as an automated thing we can download and install?

  13. #12
    The directories you are looking for are on your Mac, not your iPhone. Files are on your computer.

  14. #13
    What's Jailbreak? alin0s's Avatar
    Join Date
    Aug 2007
    Chicago, Illinois
    Thanked 0 Times in 0 Posts

    SFTP works with alpine as the password, however AFP does not work with alpine or dottie. What is up with this. Pwned using Pwnagetool 2.0.3 and pwned to 2.0.2 and it has cydia and installer on it. terminal works fine. Afping mobile with alpine works fine. but root does not work. Any ideas on how to fix it?
    check out my website at

    Keep up the hackage!

  15. #14
    I'm having the same problem with 2.1 installed on my 3g. Can't login as root, mobile works fine.

  16. #15
    I had this problem.. I went into a terminal on the mac and tried SSHing to my iphone IP and got this msg..

    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @@@@@@@@@
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @@@@@@@@@
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that the RSA host key has just been changed.
    The fingerprint for the RSA key sent by the remote host is
    Please contact your system administrator.
    Add correct host key in /Users/chris/.ssh/known_hosts to get rid of this message.
    Offending key in /Users/chris/.ssh/known_hosts:3
    RSA host key for has changed and you have requested strict checking.
    Host key verification failed.

    So the fix I used, not being a linus/unix guru, was to manually change the IP address on the iphone then try to SSH in again.. This solved the problem.. Can login as root with alpine as the password now.


  17. #16
    i cant login afp via root just mobile im on 2.1 anyone know a fix?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts