I just got a replacement iPhone, to replace a water damaged iPhone for a replacement cost of $249.00 (I exchanged it in Las Vegas, I live in Ottawa Canada)

It came with Firmware 1.1.3 Bootloader 4.6. as I was running my old iPhone on Rogers (Canada) the guy at the Apple store could not activate it, we put in the original ATT Sim card, pluged into a computer and got the activation screen in iTunes, all OK.

When I got home on Sunday, I checked ModMyI to see what is happening with 1.1.3 boy was real happy to see there was a working unlock.

After reading the instructions 3 or 4 times I said OK lets give this ago.

I downgraded the Firmware to 1.1.1, with no problems, error 1015 at the end, but that’s normal. Booted the iPhone out of recovery mode.
“incorrect SIM” error shows up on the display of the iPhone, and iTunes tells me the same.

Still has the original ATT Sim installed.

I upgrade back to 1.1.3 no error message on the iPhone and iTunes goes to the activation screen.

I downgrade again, to 1.0.2, 1.1.1, and 1.1.2 every time incorrect SIM displayed on iPhone and in iTunes. I upgrade back to 1.1.3 no problems.

The only other Sim I have is my Rogers Sim, get the same error message.

I have tried to use iTunes Ver 7.4 & 7.5 for the upgrade/downgrades.

Any ideas?