Let me brief you on the phone

Firmware 1.1.2 or 1.1.3 (Not sure but it is week 51).
Computer: Windows, Itunes 7.5

I have downgraded the phone which was purchased today to 1.1.1 . I did the jailbreak.
Installed the OktoPrep
Installed the BSD Subsystem
Installed the Geohot Unlock (1.1.2,1.1.3)

I tried to upgrade. However itunes gave me the option to restore. The option to update was not highlighted. Instead it said that your iphone software is up to date.

I thought it might be itunes. So I Uninstalled itunes and reinstalled 7.5.
Still no option to upgrade. I have changed computers and still the itunes on the second PC will not give me the option to upgrade the firmware.

I thought something might be wrong with the way I downgraded so I did the restore to 1.1.1 again and went through the whole process.

At that stage I recall that I check the baseband and it was 4.02.13_G and firmware version 1.1.1. However still no luck to upgrade. Please help me and tell me what I might have missed.