Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iphone 1604 error

  1. #1
    Default iphone 1604 error
    I have a problem with a friends iPhone 1st gen. The issues is when i try to restore the iphone to either 2.0 or 2.0.1 it starts to get the phone ready for restore and when it is about to start to install the firmware i get the 1604 error. I have tried a couple of times i get the same error. I have put the phone in DFU but same issue occurs. If there is anyone can help would gladly appreciate any help.

  2. #2
    put phone in dfu mode, load the firmware that comes with itunes, not the custom one. let it install on ur iphone. after this is done u have the latest firmware on ur iphone, but it is not inlocked. go thru same process as b4, except this time load ur custom firmware. u should see the image come on ur iphone that u loaded with ur custom firmware. hope this helps, gl!

  3. #3
    I have the same problem but i get it in DFU and it restore ok but gets stuck on verifying software?? any help??

  4. #4
    I did try to restore it with a normal non custom firmware but again it starts to verify my firmware and just when its about to install it gives me same 1604 error.

  5. #5
    have you tried using recovery mode instead of dfu mode. I got a 1600 error when using dfu but worked fine in Recovery mode

  6. #6
    I have solved my problem. I tried everything using my mac then i thought that I might use my brothers laptop which has windows xp on it and then installed itunes 7.5 and then placed the phone in dfu/recovery mode and i managed to restore the iphone to 1.1.4. After that i switched back to my mac and restored the phone with custom 2.0.1 firmware and its working perfectly.
    Hopefully this might help people with a similar problem.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •