Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Text msgs got all disorganized after 1.1.3, any help?

  1. #1
    Default Text msgs got all disorganized after 1.1.3, any help?
    All my SMS messages are all over the place now. When we recieve messages we usualy get it in a chat format. first their message, then ours, then theirs, then ours. with a time stamp to see when the message was delivered.

    After instaling 1.1.3, I recieve a message, then I send mine and then when I recieve their next reply, it puts their reply under THEIR last message, unlike before which used to be under mine. and it doesnt add a new time stamp either, it thinks it had been sent at the same time at the last one so I end up having a conversation in which it seems like the last message sent was my first message.

    I know this may not make sense but in short, the SMS app is screwed up... any fixes?

  2. #2
    Livin the iPhone Life nickh's Avatar
    Join Date
    Sep 2007
    Melbourne, Australia
    Thanked 148 Times in 118 Posts

    I hear ya mate, I have the same problem, but i guess this is the only fault i have after going to 1.1.3 not a big issue but would like to know the fix if anyone has one.


  3. #3
    Go to and put the correct time manually , as much to the second possible. Follow . Turn off SET AUTOMATICALLY and TIME ZONE SUPPORT It is easy. It really is.

    If you are experiencing weird issues with SMS and/or email sorting after upgrading to 1.1.3, this is for you. I've seen many complaints around the net on this issue and even Apple seem to struggle on it.

    My guess: this is a *real* bug Apple left out when released the update.

    SYMPTOMS: after upgrading to 1.1.3, when you receive a SMS the timestamp is wrong and therefore it's placed out of order in conversation.

    DETAIL: you don't live on the West Coast and all received SMSs have a fixed time offset. Guess what? It's what's between you and Cupertino.

    CAUSE: the timezone database in firmware 1.1.3 has wrong default permissions for user "mobile". After upgrading to 1.1.3 your timezone may default to Cupertino, especially if you had to rollback from Nate True's and downgrade to 1.1.1. You try and set it back to the right zone but system time doesn't change. Then you tune system time to your own and voilą, you created an offset between you and the system (which still believes it's Cupertino time) fooling the phone and yourself.

    SOLUTION: turn on WiFi on the iPhone, ssh yourself into the system and fix timezone database permission:

    chmod 777 /var/db/timezone

    Then enter Settings / Date&Time and change your timezone back and forth, you'll notice system time will immediately follow accordingly (that was NOT true before the fix). Set timezone to your own, correct system time to reflect your time and you're done.

  4. The Following User Says Thank You to dnoc For This Useful Post:

    Effortless (2008-02-05)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts