Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: SSH error after 1.1.3 update help!

  1. #1
    Default SSH error after 1.1.3 update help!
    hi everyone. I use Fufu to ssh into my iphone and it have worked fine for me when i was at 1.1.2. However, after i update it to 1.1.3 ssh will not allow me to log in anymore. it says something like " Warning remote host identification has changed" can anyone help me with this thnx. i really need to ssh my iphone.

    anyone at all that can help me? thanx
    Last edited by im-foney; 2008-02-05 at 02:10 AM. Reason: Automerged Doublepost

  2. #2
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Location
    Orlando, FL
    Posts
    121
    Thanks
    10
    Thanked 3 Times in 3 Posts

    When do you get this error?
    Are you using root and alpine?
    Major credit to the Programmers.
    Your efforts makes the IPHONE that much better. Thank You! Without you, There is no Us!!

    I believe in beta testing for free and paying for Smooth integrated, Compatible, and functioning Apps.

  3. #3
    yes i am using root for username and alpine for pw. i get this error during the attempt of connecting to my phone right before they ask for password.

  4. #4
    type

    rm -f ~/.ssh/known_hosts

    into terminal

  5. The Following User Says Thank You to bchilton9 For This Useful Post:

    Mann22 (2008-02-05)

  6. #5
    what does that do?

    nice! it worked thnx a bunch bchilton!
    Last edited by im-foney; 2008-02-05 at 06:58 AM. Reason: Automerged Doublepost

  7. #6
    Green Apple
    Join Date
    Aug 2007
    Location
    Boston, MA
    Posts
    40
    Thanks
    4
    Thanked 1 Time in 1 Post
    Quote Originally Posted by im-foney View Post
    what does that do?

    nice! it worked thnx a bunch bchilton!
    There's a file on computer that logs hosts that have been connected to...this command removes that file and get's rid of the conflict that you are/were having....very useful...should be a sticky somewhere.

  8. #7
    Easy. Each time you reinstall SSH, the random host-key is regenerated. To make sure one host doesn't pose as another, your local ssh client keeps a database of these hash keys, and if it changes, it refuses to connect, because the assumption is there that some machine might pose as another, which would be a security risk (e.g. phishing of passwords).
    simply edit ~/.ssh/known_hosts to remove the line that has your iPhone's key, or else, just delete the entire file.

    rcfa

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •