Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Impossible recovery

  1. #1
    Default Impossible recovery
    gusy i have an iphone that is stuck nonstop in teh itunes logo, my computer wont recognize it, ive tried forcing into recovery or even reformatting it but it will not simply work, im ready to call it quits but im hoping someone can help me, the home key after turning it off will not work , and using the on off switch with the home key just restarts it but its still stuck at the itunes logo .... any ideas?

  2. #2
    i had the same problem....
    what i did was
    1. force shutdown (hold lock button and home key)
    2. power on
    3. try entering DFU mode (hold lock and home, after screen dies still hold home)
    4. force shutdown if fails DFU mode
    and on and on..after about 10 tries of that DFU mode kicked in so i quickly restored

  3. #3
    ive tried that nonstop for about 4 hours and it hasent done anything

  4. #4
    had this happen to my old iphone once, did DFU restore and nothing...

    took it too the apple store and found out that hte harddrive was broken, thats why it couldnt go past the logo.....

  5. #5
    i thought the iphone didnt have hard drive i thought it was all nand flash memory

  6. #6
    Try this. Download ziphone from ziphone.org

    When you open the program, have your iPhone connected. There's an option under advanced settings to set the iPhone into DFU mode. Have it do that, and then your Itunes should recognise the phone in restore mode, and you should be able to restore.

    If that doesn't work, your phone really may be broken.

  7. #7
    I had the same problem, You hold both(home & power button) for six seconds and then let off the top, but keep holding the bottom until your PC makes a sound recognizing a USB. (Screen will stay black). After that iTunes will ask if you want to restore it, but before all that let me give you this link, just in case you have T-mobile.

    Downgrade your 2.0 iPhone to 1.1.4 - iClarified version | iPhoneIndiaBlog.com

  8. #8
    yea the thing is my comp wont recognize **** lol

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •