So I recently posted:

"Hello I've recently purchased an iPhone from a guy. He told me that this iPhone was "locked" meaning it had just been taken out of the box, I assumed this was okay so i bought it, (by the way I live in the UAE), and when i switch it on it said "connect to iTunes".

I did so. And it showed me all the information about the iPhone as "n/a". So i did a forced restore with version 1.1.1, the restore failed. So i restored it with version 1.0.2 and it worked. So it took me to the activation screen. All is perfect. I try to slide the "slide for emergency" but it doesn't move. So i tried to switch off by "slide to switch off" and still.. No response.

So I assumed that either that either the screen was broken or the baseband was corrupt/bricked. Any solutions? Please help. The screen is not responding whatsoever. I did hardware reset by holding down home and power buttons but no success. Sorry for the long story but I couldn't exactly cut it short."

Okay so I got a guide that told me to restore to 1.0.0 to get the slider back, and then boot out of DFU with iBrickr 0.91
I did as told and the slider problem presists. Please help me.