Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Bricked? Or screen problem? Help please.

  1. #1
    Default Bricked? Or screen problem? Help please.
    Hello I've recently purchased an iPhone from a guy. He told me that this iPhone was "locked" meaning it had just been taken out of the box, I assumed this was okay so i bought it, (by the way I live in the UAE), and when i switch it on it said "connect to iTunes".

    I did so. And it showed me all the information about the iPhone as "n/a". So i did a forced restore with version 1.1.1, the restore failed. So i restored it with version 1.0.2 and it worked. So it took me to the activation screen. All is perfect. I try to slide the "slide for emergency" but it doesn't move. So i tried to switch off by "slide to switch off" and still.. No response.

    So I assumed that either that either the screen was broken or the baseband was corrupt/bricked. Any solutions? Please help. The screen is not responding whatsoever. I did hardware reset by holding down home and power buttons but no success. Sorry for the long story but I couldn't exactly cut it short.

    Any help is appreciated.

  2. #2
    A friend of mine has an originally 1.0.2 iphone (which was upgraded to 1.1.1) with the issue where his phone occasionally reboots and then looses the touch capability at the activation screen (eg. the slide to unlock doesnt work).

    I found out from him that while using 1.0.2 and anysim unlocked, he had no issues, but the phone was not virginsed before the update to 1.1.1, then re-unlocked using anysim 1.1, and then the problems started.

    So my first aim was to get the slider back, then revirginise it using the Virginising tools in the repository http://i.unlock.no

    NOTE: For all iTunes restores, i used iTunes version 7.4.3.

    First step:

    fix the slider:

    *****REMOVE SIM CARD!!*****

    1. Attach USB cable to laptop and phone, then put phone into DFU mode (his could be put into dfu mode) buy holding both buttons till screen turns off, then releasing top button while keep holding the home button.
    2. Download the very first and original ver 1.0 restore file from http://www.iphone.unlock.no/#restore-firmware-files
    3. In itunes, restore to firmware 1.0 and wait for the error message at the end
    4. Use ibrickr 0.91 to boot out of DFU mode
    5. Check the slider - it should now be working

    Virginise to fix the baseband, firmware and secpack & back to a working 1.1.1:

    1. Attach to USB and put phone into DFU mode as noted already above.
    2. Download 1.1.1 firmware from same location noted above.
    3. in itunes, restore back to 1.1.1

    ****UNPLUG FROM USB****

    4. insert a SIM card (any GSM sim), ignore the "incorrect SIM", etc messages and do the *#307# etc, jailbreakme AppSnap method

    ****REMOVE SIM CARD!!!******

    5. once jailbroken, add the following repository in the installer - http://i.unlock.no and then refresh the sources
    6. In installer, go to "SYSTEM" and install the BSD SUBSYSTEM (MUST BE INSTALLED BEFORE virginising)
    7. Ensure the screen lock is set to "never"
    8. look for the UNLOCKING section under installer, and select the VIRGINISING by fredrik (1.8mb version) - Do not install OneSIM
    9. install the VIRGINISIER and wait 10 minutes
    10. after the virginiser has fixed the baseband, secpack and firmware, put the phone into DFU mode again as above
    11. Attach to USB and put phone into DFU mode as noted already above.
    12. in itunes, restore back to 1.1.1.

    ****INSTALL SIM CARD now****

    13. Jaibreak using the jailbreakme.com method (*#307# etc etc)
    14. in the installer, go to SYSTEM, and install BSD SUBSYSTEM
    15. in the installer, go to UTILITIES, and install AnySIM 1.1
    16. Ensure the screen lock is set to "never"
    17. run AnySIM from the home menu
    18. Unlocked!
    19. Done..!

    Hopefully this helps you out guys - from my experience. I understand that when the screen locks itself it has a firmware malfunction, probably caused by a bad unlock or upgrading from a previously software unlocked 1.0/1.0.1 or 1.0.2 firmware version without virginising properly. If the phone was an OTB 1.1.1, then there was probably a bad firmware upgrade from 1.0.2 during the manufacture in China (the majority of 1.1.1 phones were just upgraded from 1.0.2, before release to stop hacking and unlocking)

    Cheers

  3. #3
    Thanks for the reply I'll get to right away and tell you how it goes


    EDIT:

    I restored it with the 1.0.0 file and booted out of DFU with iBrickr and the screen still doesn't work.. I'm in a really awkward position now and don't know what to do. So I restored back to 1.1.1 and still didn't work. I tried again with 1.0.0 and it still didn't work. The most important part is the slider for me



    Please please please help me
    Nobody understands my problem more than you guys!

    Sorry for the double post but I really need some help its really urgent
    Last edited by dahab92; 2008-01-18 at 08:58 PM. Reason: Automerged Doublepost

  4. #4
    you can press sleep button so that the screen turns off then quickly press it again and now the slider should work until the next time iphone falls asleep
    i have the same problem on one iphone. seems it doesn't matter which firmware or unlock method you use. when someone calls or when you press a button to wake the iphone the slider won't move, only when you press sleep button twice more (and you drop the incoming call)
    if anyone knows how to fix this please help

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •