Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: IPhone behaving strangely after applying an Invisible Shield???

  1. #1
    Default IPhone behaving strangely after applying an Invisible Shield???
    Hi All!!!

    I just applied an Invisible shield to the front screen of my Unlocked Iphone 1.1.14 and now the screen/icons are activating by themselves mostly in the lower left hand side of the screen, like the screen is being pressed by itself???

    It says to leave an invisible shield for 24 hours or so until it drys out until turning on the Iphone again but i decided to take the Invisible Shield off as i wasn't happy with the result...

    Seems very strange behaviour, was working perfectly before applying screen protector?

    It took me awhile to apply it e.g. getting out air bubbles etc, but i don't think i was being overly aggressive with the process...

    The phone was in standby mode and the screen was off while applying the protective screen

    So why on earth is it doing this???


    Cheers!

    Diamond

    59 views no comments!!!!

    What?

    Can someone comment on this Pleeeeeeze!!!
    Last edited by DiamondSage; 2008-07-14 at 03:43 AM. Reason: Automerged Doublepost

  2. #2
    If i touch the side of mine, it will open the nearest icon.

  3. #3
    Well this is opening an icon but i'm not the one pushing the icon???

    I've turned it off and will leave it off till tomorrow morning, hopefully that will fix it...

    Seems absurd that this would have that affect...

    I'd like to hear some more replies from people about this
    Last edited by DiamondSage; 2008-07-14 at 02:17 AM.

  4. #4
    Green Apple
    Join Date
    May 2008
    Posts
    60
    Thanks
    20
    Thanked 2 Times in 1 Post
    Quote Originally Posted by DiamondSage View Post

    The phone was in Standby mode and the screen was off while applying the protective screen

    Maybe thats why...you should turn the phone all the way off...before applying the shield..

  5. #5
    Yeah, but geeze i've read no horror stories of this EVER happening before
    I'm sure one person on the planet must have experienced this...

    I'm interested in the resolve here!

    Or at least someone with some knowledge about this...

    Edit:

    Okay I left it with the "Power Off" completely for approximately 30 hours,
    turned it back on and now it's all back to normal!!!!!

    Yayyyyyyyyyyyyyyyyyyyyyyyyy

    So for anyone that encounters this exact issue, i hope your reading this post right now...

    With a little patience your IPhone will be fine!!!



    Diamond
    Last edited by DiamondSage; 2008-07-15 at 12:51 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •