Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Need to Unlock 2.0 in Australia?

  1. #1
    Default Need to Unlock 2.0 in Australia?
    I live in Brisbane, Australia, and am currently using a first generation, unlocked 1.1.4 iPhone on the Telstra network. Now that Telstra carries the iPhone, will upgrading to 2.0 still require me to unlock my phone, or can I just upgrade and start using my phone as is?

  2. #2
    Don't upgrade to 2.0! You cannot unlock that yet. They are working on the patch! I am having to downgrade it from 2.0. I made the big mistake of upgrading to 2.0. It's a huge pain!

  3. #3
    Livin the iPhone Life reeko's Avatar
    Join Date
    Dec 2007
    Location
    England
    Posts
    1,562
    Thanks
    48
    Thanked 164 Times in 135 Posts

    and yes, your tariff is not a registered iphone tariff so you will need to unlock it.

    hopefully this week it will come as the dev team has announced that the firmware and new iphone can be unlocked.
    The Original Autobot of MMi
    Jesus couldn't turn into a fire engine


    LOL -> "Winterboard does not interfere at all with my performance."

    Suck it up, Sucker

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •