Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: I really need some help

  1. #1
    Default I really need some help
    I have a 4GB iphone and I'm having some difficulty with it. All help is greatly appreciated. Here's what the phone is doing:

    1. When plugged in with the power adapter and dock, the Apple logo turns on and then shut's off...repeatidly and it doesn't stop.

    2. When the phone is plugged in with just the power adapter, you can turn the phone on, the Apple logo appears, then it shuts off.

    3.Nothing happens when plugged into the computer.

    4. Nothing happens when you try to power it up connected to nothing.

    I was wondering if this was a dead battery. I ordered a new battery, but before I install it, I just wanted some input. The phone has been unlocked and already opened once...so there goes the warranty. I want to thank everyone for their help in advace.

  2. #2
    My friend had the same problem. Try holding down the sleep button and home until the phone reboots. 25-60 sec's i think and it ended up working for him.

    I hope it works.

  3. The Following User Says Thank You to straightryder For This Useful Post:

    brent91055 (2007-12-26)

  4. #3
    I appreciate the help, but that didn't work

  5. #4
    Quote Originally Posted by brent91055 View Post
    I appreciate the help, but that didn't work
    It should work... Your phone should Benin restore mode with a yellow triangle...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •