Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help, my GSM won't work.

  1. #1
    Default Help, my GSM won't work.
    So I bought an iphone off ebay, it was 1.1.2 Firmware and most of the functions seemed to work fine. I put in a prepaid gophone sim card, thinking I could just dial 611 and get going, but no sale. The phone consistently says "No service" no matter where I am.

    I Upgraded to 1.1.4, no fix.

    I reflashed the baseband to various versions, no fix.

    I went and got a NEW sim card from the AT&T store, still no go.

    The phones wifi (and presumably bluetooth) work fine. It shows the correct ICCKD for the sim card I put in it -- and it shows a 01 1301000 IMEI (I recall reading it showed some other numbers with the corrupted sec zone issue).

    I've considered various possibilities as to what might be wrong. I thought perhaps the sim card I bought might have been foreign and would have needed to run iworld, but that only works with 1.1.2 (although I was runnign 1.1.2 when I initially put the card in, but not anymore). I thought perhaps the previous owner might have used and older version of anysim that messed up the seczones but that doesn't seem to be it.

    In short, I've tried almost anything I can think of to make this stupid phone work, but so far all I have is an ipod touch with a camera (although I guess I did pay less than I would have paid for an ipod touch, this is not an appealing prospect to me, as I need a phone).

    I'm posting this in the hopes someone out there might know the answer. My last option, which I will resort to soon, will be reflashing 1.1.4 on the phone, not jailbreaking it, and taking the whole thing to the Apple Store and throwing myself on their mercy. That, however, is not a short drive and I'd really like to avoid that (plus I'm not 100% sure the phone is still covered, though I believe the seller said it was covered until november).

  2. #2
    upgrading can usually take the problems from before into the upgrade

    try putting your phone in dfu mode (plug the phone into the computer, press and hold the home and power keys, release power key but still hold home when the screen shuts off, then itunes should see the phone in dfu mode and reflash 1.1.4-make sure your not just getting any 1.1.4 from anywhere, either get it from here or directly from itunes

    if the home+power button wont get it in dfu mode, then download ziphone and use it to put the phone into dfu/restore/normal modes =]


    hopefully the restore will fix the problem, previous owners who screw up their phones and dont feel like fixing it tend to sell them so it becomes someone elses problem, if the restore dont work, shoot an email to the seller and simply ask if this was a problem they had or what they may have installed or did to it

    if all else fails just head to the apple store(and make sure the phone isnt obviously jailbroken-so either way a restore is what youll need to do. the serial number on the back of the phone tells them weather or not its under warranty, no paperwork necessary-except you sign paper stating the iphone was replaced on such and such date =]
    Last edited by movalwebmaster; 2008-06-20 at 09:47 PM.

  3. #3
    iPhone? More like MyPhone jfmsam's Avatar
    Join Date
    Dec 2007
    Location
    Florida
    Posts
    109
    Thanks
    0
    Thanked 10 Times in 9 Posts

    Unless you have a legit AT&T iPhone plan, every time you restore make sure you activate and unlock it. This applies as well when you insert an AT&T SIM from a regular account.

    Don't use Ziphone. Use iLiberty+ or WinPwn/Pwnage tool and install 1.1.4.

    Make sure you are inserting the SIM properly...

  4. #4
    Thanks for the suggestions, I have unlocked/activated the phone multiple times. I'm pretty sure that's not the problem, when I leave it unactivated, and I have the option to "slide for emergency", even the 911 call option shows "no signal" in the upper left. I'm pretty sure that's wrong.

    So I guess its off to the Apple store for me. Let's hope that gets it fixed. Thanks again.

  5. #5
    Quote Originally Posted by Faxmonkey View Post
    Thanks for the suggestions, I have unlocked/activated the phone multiple times. I'm pretty sure that's not the problem, when I leave it unactivated, and I have the option to "slide for emergency", even the 911 call option shows "no signal" in the upper left. I'm pretty sure that's wrong.

    So I guess its off to the Apple store for me. Let's hope that gets it fixed. Thanks again.
    Try this...it's a long shot but it works for me everytime my iPhone shows me "No Service"
    1. Ensure the area you are in has coverage - Reading your comments above, you do seem like a guy who knows that he is doing So I am sure you must have done that. But let's just play around here okay. Select a sweet spot where you have full signal bars with your SIM on some "other" phone (same SIM that you are gonna use in the iPhone but on a different handset).
    2. Once you've determined such a spot, take the SIM out from this "other" phone and put it back in your iPhone.
    3. I am sure iPhone is going to say "No Service" - provided your observations above are correct.
    4. Now enable the Airplane mode and keep it on until a minute or so.
    5. Disable the Airplane mode. The phone should go into searching state.

    I am not claiming this would work for you, but it might...u never know
    Last edited by ajrulez; 2008-06-21 at 08:50 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •