Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cannot restore ,make & receive calls - pls help.

  1. #1
    Default Cannot restore ,make & receive calls - pls help.
    Hi there

    I have an iPhonewith firmware v.1.0.2 that I tried to jailbreak using iLiberty+. After I ran iLiberty I got a message that I cannot make or receive calls and that the phone needs repair. I searched the threads and restored the phone in iTunes so it now has v.1.1.4. Then I tried to unlock and jailbreak it in iLiberty again but can't get anything to work (service, wifi, youtube). Is there any way to fix this? I'm completely new to this stuff so pls bare with me. Any help greatly appreciated.

  2. #2
    I think you have a corruptbaseband like me. when you restore in itunes do you get an error message 1011. If or you can try ieraser to eraser you baseband so you can flash the new baseband

  3. #3
    if you have 1.1.4, use Ziphone to unlock your phone. Dont stress out.

  4. #4
    I got an 1604 error message the first time I tried to restore it, but the second time it worked OK. The firmware still shows 1.0.2 in iTunes. Did ieraser work for you? Where can I download it?

  5. #5
    No because my baseband is very corrupt. Any restore i do i get error 1011. i thought error 1604 was a usb error when you go setting what does it say is you modem firmware

    need help just send me a private message

  6. #6
    OK, finally got the issue resolved after several attempts of restoring and upgrading a couple of times and then running iLiberty. Thanks for the replies.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •