Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: changing autocorrect language...?

  1. #1
    Default changing autocorrect language...?
    hi guys!
    first post!
    from my iPhone no less!

    Anyway,I am wondering,now that I have 1.1.2 setup, how do I go about using French autocorrection while keeping the keyboard qwerty and the OS English?

    This is why I upgraded.


    I fear I must wait for someone to write a tweak for it

  2. #2
    Join Date
    Sep 2007
    Atlanta, GA
    Thanked 18 Times in 18 Posts

    do u like take a french class or something? anyway...idc....go into the interface and browse around and find out what u can sure there is something u can do....i would do it for u but i have 1.1.1

  3. #3
    well all my friends speak french... I live in belgium so virtually all my messages are sent in french but i've learnt to type on a qwerty keyboard

    now I've noticed that if I change the keyboard over to azerty it'll auto-correct everything in french...

    Thanks anyway... hope someone has a clue

  4. #4
    I have the same issue with my frenchly-challenged iPhone; it's either qwerty in english or azerty in french.... I can't believe Apple has been so short-sighted to forget about us poor french canadians and belgians who like qwerty.

    Anyone with a solution yet?

    Alright, after posting this I found a hack on another site that actually works. The idea is to trick the en-UK keyboard language into using the french dictionnary files. This results into a qwerty keyboard that auto-completes/corrects in french.

    To do this, log into your iPhone using ssh and go into /System/Library/KeyboardDictionaries. Next, copy the fr_FR* files over the en_GB* ones of the same name. Keeping a backup of the latter is probably a good idea. After that you just need to add the UK language in Settings -> General -> International -> Keyboards and switch to that layout whenever you need it with the earth icon.

    Credits to pengouinqc over here:

    Last edited by flaroche; 2008-01-08 at 04:56 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts