Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help needed - Restore/Upgrade over SSH WiFi possible???

  1. #1
    Default Help needed - Restore/Upgrade over SSH WiFi possible???
    The other day my 1.1.1 iPhone started playing up, specifically after installing the latest installer update.

    The net result is basically a constantly re-booting iPhone, home button no longer works and not recognised by any apps on my MacBook Pro or under Windows. It also won't go into restore mode by any of the usual methods.

    When it's switched on it sometimes displays a 'Accessory not supported' message when plugged into my Mac.

    I can still SSH to it over WiFi perfectly and it seems to just have a corrupted OS.

    Is there any way to virginize it from the command line on the phone? I presume I can copy the 165MB ipsw file to it, but I can't see how I can essentially do a restore if a host PC with iTunes on it can't see it over USB.

    Any help appreciated!!!!

    bump..

    Maybe the question should be -

    "How do I tell the iPhone to go to DFU or restore mode from the command line on the iPhone itself?"

    I know that iPHUC has the enterrecovery command, so does anyone know what this actually calls on the iPhone?

    The other option I've considered is to grab another iPhone, tarball the OS as though I was setting up dual boot and transfer it to the bricked phone, setting up dual boot on it.

    c'mon guys... give me some ideas!

    Last edited by Bishop2K; 2008-05-23 at 12:15 PM. Reason: Automerged Doublepost

  2. #2
    I am facing the same problems since some weeks now and impossible to find a solution....

    Have you managed to fix it by now?

  3. #3
    I would like to know also

  4. #4
    Have any of you tried forcing the thing into DFU mode? I am almost sure that that would do the trick.

    With the phone on and connected to iTunes do this.

    1. Press the Sleep/Wake button and home button at the same time and hold them down.
    2. Once the phone goes completely black release the Sleep/Wake button but continue to hold the Home button.
    3. You should hear the computer make a sound recognizing something USB has been plugged in. At this point you should also see iTunes recognizing your phone again.
    4. Release the home button now.
    5. Hold Shift(Windows)/Option(Mac) and click restore in iTunes.
    6. Browse to the latest ipsw file on your computer and let iTunes do it's thing.

    If you can't get past the third step here is some more advice. Yes, I have had a constantly rebooting iPhone and yes I have been able to recover it. Keep trying and eventually you will get the thing into DFU which will allow you to bring it back to life.

    P.S. Since you can SSH into the unit I would suggest backing up your contacts/sms/voicemail/etc before beginning this process.
    "Count your blessings. Make your blessings count!"

    Is that an iPhone in your pocket?

  5. #5
    Quote Originally Posted by sr20_00 View Post
    Have any of you tried forcing the thing into DFU mode? I am almost sure that that would do the trick.
    I've tried your suggestion, but I'm having no luck.

    I have them same symptons as explained by the OP, and also havn't had any luck. I was thinking the along the same lines as the OP about using ssh to restore my phone, but again, no luck.

    Any more suggestions would be appreciated.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •