Results 1 to 1 of 1

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: battery won't charge PLEASE HELP.

  1. #1
    Default battery won't charge PLEASE HELP.
    For some reason when I connected my iPhone to charge for the night it wouldn't charge. Instead it gave me the "you've connected a whatever device do you want to go into airplane mode". I tried it on three different chargers. My room mate has an iPhone also and his works on all of the charger and mine works on none.

    More than that, it doesn't get read by iTunes. I can't restore it because it doesn't read it. I'm down to 10% and I've tried everything. I reset everything from within the settings, including reset and delete all. I've cleaned the input, by blowing and then with a small swab. It knows that something is going in, because it gives me the airplane mode warning, but it doesn't charge and iTunes doesn't read it.

    I can put it into recovery mode, but the iphone gives me the iTunes logo, but iTunes still doesn't read it. I'm panicking because once the battery is dead, I don't know what the hell I'm going to do.

    I am afraid to take it to the store because it's jailbroken. Not unlocked, but still I know they won't fix it. Unless they fix it when the battery is dead, and then they won't know it was jailbroken until after it's fixed and powered up. But I really don't want to take it in.

    please help.


    *update:

    I turned it on and it suddenly seems to be charging and connecting to iTunes like normal. I don't want to touch it or do anything to it until I've gotten as much charge out of it as I can.

    The only thing I can say is that I restarted my computer (iMac) while the iPhone was plugged in. Actually it was a hard restart of the iMac, (holding the power button). I don't know why this would make sense, because I tested it on a wall charger and a charger connected to my room mates computer and those didn't work, so it's not the computer, but maybe the restarting of it while connected to the iPhone. Or it may just be a fluke and it's charging for no real reason.
    Last edited by javierpuga; 2008-04-24 at 01:14 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •