Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Problem with Permissions and freezing phone

  1. #1
    Default Problem with Permissions and freezing phone
    So I was trying to get my savegames working for gsPhone, snes4iPhone, etc, by modifying permissions/owner as I read in several of threads. After making sure permissions were set on the mobile directory (wrx for group, owner and others), save games were still not working. My next step was to modify permissions on the entire applications directory to wrx for everyone. This didn't seem to help either, but then I thought, maybe I need to restart my phone to make it take effect. However, after restarting my phone is behaving *very* oddly. When I boot, it seems to boot as normal, but once it arrives on the slide to unlock screen, everything is completely frozen. After monitoring this for a while, I see that it actually is working in the background, because every 2 minutes or so, the screen will change to reflect changes (signal strength and time will update, and the highlight mask on "slide to unlock" will be in different positions). Unfortunately, I cannot actually slide to unlock, and the only way to turn off the phone is to hold the power+home buttons to force it to shut down.

    My question is twofold: can modifying permissions cause this? And is there a way for me to fix this short of resetting everything by doing a repair installation of the firmware? I can't connect to it via WinSCP, as I can't get the IP address off my phone and I do not have access to my router to check the routing tables. Perhaps I can use iPhoneBrowser to connect (havent had a chance to try yet), but I don't think that program has a capability to modify permissions...

  2. #2
    Livin the iPhone Life
    Join Date
    Dec 2007
    Location
    Boston, MA
    Posts
    1,033
    Thanks
    16
    Thanked 143 Times in 138 Posts

    i just saw someone with the same problem this morning (specifically with the touch functions not working) and it was also after setting permissions to an entire directory. I'm not sure on an easy fix with this other than restore. Hopefully someone with more knowledge can advise.

  3. #3
    Default Update on the situation
    Update: I tried to restore my phone through iTunes (shift-click), but it wouldn't let me. I did find out about iPhone PC Suite, and used it to change permissions, but it had issues trying to reassign issues to the entire applications folder. I think I can do it one by one, but what are the default permissions?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •