Page 1 of 2 12 LastLast
Results 1 to 20 of 35

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cannot restore iPhone - error 6

  1. #1
    Red face Cannot restore iPhone - error 6
    Does anyone have any information about this? I've managed to get my 1.1.1 iphone into the blank screen restore state, the restore process completes, but during the 'verifying software' stage it fails and i get "cannot restore iPhone - error 6"

    any clues?

  2. #2
    POSSIBLE SOLUTION
    I have a 1.1.1 otb new phone and the same happened to me. I was desperate. I decided to check the apple support page http://docs.info.apple.com/article.html?artnum=305868. and http://docs.info.apple.com/article.html?artnum=306084. I couldn´t found error 9 but I tried one of the error 1603 solution....and you know? It worked!!! I connected the iphone usb cable to another usb port. After that I continued with no problems with the whole unlocking process with no problems. Hope it works

  3. #3
    try restarting your computer and iphone as well.

    then start DFU mode on iphone (hold sleep + home key for 10 secs and release sleep key while still holding home key) then restore to 1.1.1

  4. #4
    Tried that already, no joy
    might try restoring in windows.

  5. The Following User Says Thank You to benfilan For This Useful Post:

    blockboy (2008-06-27)

  6. #5
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Location
    San Diego, CA
    Posts
    138
    Thanks
    3
    Thanked 28 Times in 13 Posts

    I had the same error on restoring to 1.0.2 from 1.1.1..

    Errors I keep getting was (1), (2003), (6) and alot more of those including the unable to restore blah blah..

    **I'm on windows xp**

    I tried to do one more step using Ibrickr latest ver 0.91 while Itunes still open on restore mode then I open up Ibrikr, since my phone still on recovery mode need to be restored Ibrickr pick it up and fix it then guide you all the way up to the activate mode.

    I am assuming you already have the fw 1.0.2 downloaded.

    Itunes was open cause Itunes will do the forced restore after ibrickr fixed the file. Then AFTER the forced restore, ITUNES still says ERROR on restoring the fw. soo jump back to ibrickr which already know will have this issue. you will have 3 options.. with mine stuck on recovery mode AFTER the restore.. I chose the #2.. then another guide. If you get to this part, mine was on red color so I waited and ibrickr did some kind of reflashing then after 3-5 mins of wait there it goes..... ACTIVATE using ITUNES.. I use this guide all the way http://modmyi.com/forums/showthread.php?t=10461

  7. #6
    this isn't working for me. ibrickr can't repair the file

    I've tried to downgrade literally about 40 times so far, always fails. always error 6, i've tried doing it in windows, on my imac in OSX, on my macbook....nothing works. i'm at my wits end.
    Last edited by benfilan; 2007-10-22 at 10:10 PM. Reason: Automerged Doublepost

  8. #7
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Location
    San Diego, CA
    Posts
    138
    Thanks
    3
    Thanked 28 Times in 13 Posts

    Is your phone still on the yellow triangle mode? or if you just downgrade from 1.1.1and have the new itunes and usb image when you connect to Ibrickr? I have all those with itunes open and a popup window asking me to restore it. Then I Open up Ibrickr, found the iphone on restore mode and asking me to restore it, so I hit yes or whatever the button for me to hit to continue.. **It was very late last night my brain half dead and can't remember the exact option** but anyway, I hit the restore button on Ibrickr.. then before it proceed, ask me to ensure to have the FW 1.0.2.ipsw, I download that from here http://modmyi.com/forums/downloads.php?do=file&id=479 and saved it to desktop. then I hit yes **still on ibrickr** Ibrickr found the file and extract it to the Ibrckr folder. then it says to go ahead and hit restore on Itunes using SHIFT + down arrow then direct it to your Ibrickr folder and choose the 1.0.2 then hit restore.. (Ibrickr will have the note saying after its done hit the back button)

    after restore itunes still have the error on restore.. back to ibrickr hit back button and now I have the 3 option.. hopefully this might work for you too.

  9. #8
    the iphone will not restore in itunes at all. it either fails halfway through and i get error 6, or it gets stuck about a third of the way through and never completes.

    oh, and i was 1.0.2 i accidentally upgraded to 1.1.1 and now i'm trying to downgrade again. and i constantly get error 6 and the itunes/cable logo.
    Last edited by benfilan; 2007-10-22 at 10:42 PM. Reason: Automerged Doublepost

  10. #9
    i get error 6 error 1 but my most recent error is that itunes says "There was a problem downloading the iPhone software for the iPhone "myiPhoneName". The requested resource was not found."

    Hmm now i can't restore my iphone at all... If i hold down the power and home button i get to the connect to itunes but its not the yellow sign anymore... its the windows itunes icon with the iPhone cable. If i do this method i get the error 6 if trying to restore with 1.1.1 and i get the error 1 with trying to restore to the 1.0.2. Nethier work... and when i just try to restore without choosing a firmware i get the "There was a problem...." blah blah blah.

    Tried uninstalling itunes deleting all the itunes folder in program files and documents and settings. also when i hold the power and home button and go to recovery mode i get stuck there... my only way out is to try the apptapp method to downgrade but that also gets stuck on step1 but it able to boot my phone back to normal operation but that's about it....

    I want to restore.... but can't... i going try to do it at the apple store tomorrow.

    update
    NVM
    hahaha got
    used ibrickr 9 to downgrade.... now i can't upgrade iTunes says that 1.0.2 is the latest version... LOL i want 1.1.1 back...
    Last edited by 808mp5; 2007-10-23 at 11:00 AM.

  11. #10
    i'm still getting error 6 :'(

  12. #11
    Default Hi!
    Hi! I'm new and sorry for my english but I'm Italien.
    I've the same problem. My iPhone don't show on screen logo or other. It's black. I connect the charger and not charge the battery. I press the sleep and home key and it go in recovery mode but the display is off. I connect itunes and the iPhone's display show white. Itunes want to restore iPhone. During the restoring the display of iPhone show apple logo and at the bottom the circle, but at the end of verifyng firmware it say error (6) and iPhone stay black.
    I've got a same of tentativ but error 6 come evry time.
    Can you help me? Thank's

  13. #12
    I was running into the same error. Basically, I used ibrickr to put my phone into DFU mode, and try to restore. Didn't work. Then you know how it says if your screen is red, you're good, phone is rebooting. Green, means restore with iTunes? I don't know how I managed to get it green, but after I did, iTunes restored it no problem at all.

    Your restore file, are you accessing it directly by holding shift (option for mac) and then clicking restore?

  14. #13
    Hi! I restore iPhoene with ibrickr but display is white, only one time it is red. But at hte end come's white

  15. #14
    Turn the phone off by holding the sleep button and the home button for about 10 seconds. If the phone doesn't automatically restart, turn it on manually by pressing the sleep button. If ibrickr is open, close it. When the phone tries to restart, it will more than likely either give you the yellow triangle, or the plug and iTunes logo. Now restart ibrickr, and it should detect the phone. Then click on "Boot Phone" .. and see if that works. If the screen goes red, then you're fine. If it locks up again, repeat the process, but instead, click on "Begin 1.0.2 downgrade/restore", and then follow instructions.

  16. #15
    sorry i've say red but my display is green...i've many time restore and iphone is hot. Can I another thentative? Thank. My iPhone after restore is black I see null on display

  17. #16
    If your screen was green, then you should be able to upgrade/restore through iTunes no problem. Are you selecting the file you want to restore? Are you on 1.1.1, or 1.0.2? Did you download the .ipsw file already, and have it stored somewhere locally on your computer? If you did, then when the green screen is there, open iTunes. It should say that it needs to restore. Now hold down shift (option if you use Mac), and click restore. Then navigate to the .ipsw file.

    If you haven't downloaded the restore file, then do so now. Search the downloads.

  18. #17
    i've donloaded the 1.0.2 firmware and place in the ibrickr directory. The restore in itunes display on the iphone the logo apple and the circle, but ant the end of verifing firmware error 6 appear and click ok the iphone display stays white. In ibrick say that show triangle but I've not see that triangle never and when i fix or boot iphone on ibrickr display stays green. Help me...

  19. #18
    Did you use any unlocking programs, such as anySim1.0.2, or iUnlock? Sounds odd though. I restored fine once I came up with the green screen. When you see the "Restore" button, do you hold shift (or option) then click restore, and navigate to the ibrickr folder, and select the 1.0.2.ipsw?

  20. #19
    the iphone was unlocked with iunlock. And after one mont I've upgrade to 1.1.1 but at the end show triangle and error, i restore 1.0.2 but error come always. Yes I navigate and select 1.0.2.ipsw in the ibrickr directory,. But ibrickr modify the firmware after restore in itunes? thank you are very nice! Can you chat me on skype? i'm tex.miki

  21. #20
    Don't have skype currently. Thank you for the kind words though.

    If you used iUnlock, you're going to need to virginize your baseband before you attempt to upgrade to 1.1.1. Your best bet would be to virginize your baseband, downgrade to 1.0.2, and then try a fresh upgrade to 1.1.1. There are guides on here.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •