Turns out I tried firmware 1.2.0 and didn't like it (too buggy, slow, unstable, etc), so when I went back to 1.1.4, iTunes asked if I wanted to restore my phone from a backup. I tried, but it fails "not compatible" etc etc. This will happen when you try to restore a newer iTunes firmware backup to an iPhone with older firmware.

I'm not sure how this works on windows, but in OSX, iTunes backups are located at "~/Library/Application Support/MobileSync/Backup/[long hex key named folder]/". All the backups end in .mdbackup

I had remembered the last backup I did with 1.1.4 was at 10:38pm the previous night, so I deleted all the newer backups (the automatic backups iTunes did while I had 1.2.0), quit and restarted iTunes, hooked up my iphone and it automatically restored my iPhone.

I guess it didn't save all my old SMSs, icon locations and such like I thought it would, but whatever, it restored it....(so maybe there's no point since "new phone" won't do that either)....

any thoughts/input?