okay - so my iPad crashed shortly after I reinstalled my PC, and as I was having the dickens of a time with insanely long backups, I stopped doing them for a bit, leading to once a week. of course within a week of redoing my PC my JB'd iPad crashed, and the backup was stuck somewhere else, and I had to restore fresh.

I lost all my data for apps and had to take a while to extract the backup, which I did and tried to copy the information into the Angry Birds folder.

PvZ worked just fine, but AB crashed.

I tried to uninstall it, I tried to delete the folder in iFile, I tried removing it from iTunes directly - NOTHING seems to work. I can download and go through the install process, it puts the folder back into the App directory, but I'm screwed as I can't access, I can't do ANYTHING.

I had this happen before with an app, and somehow got it to work, but that seems impossible or at least improbable here.

I really don't want to have to restore, as the backup I'd be restoring to has this stupid problem...

Any suggestions? I've tried almost everything I can think of:

- Rebooted the iPad
- physically deleted the ipa from the iTunes directory
- removed the folder in the app directory through iFile
- Attempted to remove through iTunes... multiple times.

Note - this app is a legit, owned purchase, to make that abundantly clear.

Thanks... blasted stupid thing..