Page 16 of 42 FirstFirst ... 6141516171826 ... LastLast
Results 301 to 320 of 831

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Workaround Stategies for iOS8 respringing using GroovyAPI+

  1. #301
    Default Workaround Stategies for iOS8 respringing using GroovyAPI+
    ok...yeah i was talking about the switch
    but let me get on it myself first & if run into issues ill pm or hit ya up in gcf

    see how much better we r flowin NewD? feels right right? lol

  2. #302
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,708
    Thanks
    8,334
    Thanked 16,463 Times in 7,695 Posts

    Quote Originally Posted by Boots View Post
    ok...yeah i was talking about the switch
    but let me get on it myself first & if run into issues ill pm or hit ya up in gcf

    see how much better we r flowin NewD? feels right right? lol
    YES MA'AM!!! Lovin it! I'm here to help whenever you need it.. but you'll nail it yourself.. The only thing I'm asking modders is to let me 'take a look' when you're done.. since others will then mod - 'your mod' - and I just want to make sure nothing gets weird with it... Thanks, Boots!!!

  3. The Following User Says Thank You to NewD For This Useful Post:

    Boots (2015-01-22)

  4. #303
    All,

    WidgetWeather2 is finally live in Cydia on MMi repo. It will no longer be supported from my repo, so please install from there now if you want the latest version and to receive updates.

    Thanks!

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0

  5. The Following 3 Users Say Thank You to King_O_Hill For This Useful Post:

    #m37h{ (2015-01-22), chevymusclecar (2015-01-22), NewD (2015-01-22)

  6. #304
    well after reading it all my conclusion is that what is best for me to stay on regular sbhtml tweak in order to stay on convergance...(if i understood right)and my time is really modest so i can't convert my every widget
    i will get over a couple resprings a day(2-4)
    really appreciate all knowledge shared here,thank you for that Grant.
    @KOH
    thank you for WW2,we all would be miserable without it
    Last edited by #m37h{; 2015-01-22 at 06:39 AM.

  7. The Following 2 Users Say Thank You to #m37h{ For This Useful Post:

    King_O_Hill (2015-01-22), NewD (2015-01-22)

  8. #305
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,708
    Thanks
    8,334
    Thanked 16,463 Times in 7,695 Posts

    Quote Originally Posted by meth357 View Post
    well after reading it all my conclusion is that what is best for me to stay on regular sbhtml tweak in order to stay on convergance...(if i understood right)and my time is really modest so i can't convert my every widget
    i will get over a couple resprings a day(2-4)
    really appreciate all knowledge shared here,thank you for that Grant.
    @KOH
    thank you for WW2,we all would be miserable without it
    I run GroovyLock+ over top of Convergence, Meth. So I get the beauty of Convergence and no resprings from GroovyLock+. Easy to set up, bro. Been talked about a lot in the other threads .

  9. The Following User Says Thank You to NewD For This Useful Post:

    #m37h{ (2015-01-22)

  10. #306
    Quote Originally Posted by King_O_Hill View Post
    All,

    WidgetWeather2 is finally live in Cydia on MMi repo. It will no longer be supported from my repo, so please install from there now if you want the latest version and to receive updates.

    Thanks!
    Do I need to re-install it from the new Cydia repo, or can I leave it as-is from your repo? Your repo shows V 2.0-2, Cydia shows 2.0-1. Don't wanna foul it up.

  11. The Following User Says Thank You to Clem-Clone For This Useful Post:

    King_O_Hill (2015-01-22)

  12. #307
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,708
    Thanks
    8,334
    Thanked 16,463 Times in 7,695 Posts

    Quote Originally Posted by Clem-Clone View Post
    Do I need to re-install it from the new Cydia repo, or can I leave it as-is from your repo? Your repo shows V 2.0-2, Cydia shows 2.0-1. Don't wanna foul it up.
    No. 2.0-2 from King's repo is a very old beta version - even though it's number is higher than the one in Cydia. Completely uninstall that one.. And then install the one from Cydia and you'll be good to go.

  13. The Following 2 Users Say Thank You to NewD For This Useful Post:

    Clem-Clone (2015-01-23), King_O_Hill (2015-01-22)

  14. #308
    Quote Originally Posted by NewdestinyX View Post
    No. 2.0-2 from King's repo is a very old beta version - even though it's number is higher than the one in Cydia. Completely uninstall that one.. And then install the one from Cydia and you'll be good to go.
    Did that, thanks, works

  15. The Following 2 Users Say Thank You to Clem-Clone For This Useful Post:

    King_O_Hill (2015-01-23), NewD (2015-01-23)

  16. #309
    i have just try this workaround but using GB+ all of my widgets on i6 are smaller and don't fit on screen
    any sugestions?thank you

  17. #310
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Quote Originally Posted by meth357 View Post
    i have just try this workaround but using GB+ all of my widgets on i6 are smaller and don't fit on screen
    any sugestions?thank you
    Were you using that viewport scaling code June posted a while back to scale the widgets up?

  18. The Following User Says Thank You to Simon For This Useful Post:

    #m37h{ (2015-01-25)

  19. #311
    Quote Originally Posted by Simon View Post
    Were you using that viewport scaling code June posted a while back to scale the widgets up?
    no,just went from sbhtml to GB+

  20. #312
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,708
    Thanks
    8,334
    Thanked 16,463 Times in 7,695 Posts

    Quote Originally Posted by meth357 View Post
    no,just went from sbhtml to GB+
    The workaround in post#1 and 2 doesn't not address the SIZING of your widgets, Meth.. And Simon is right to point out that if you're using June's VIEWPORT code in the HTML it gets broken by using GL+/GB+..

    SO - if you want to bring an old iPhone 4/5 sized widget to iphone 6 or 6+ follow the instruction I placed in Post #3 of this thread... That's one method to get your widget to size up properly. There are several ways to accomplish it - none of them 'easy' though when working with GB+/GL+.. June's code was 'easy' - but doesn't work in WKWebView which is the 'engine' GL+/GB+ use to get rid of your resprings. But look at post #3.. that's what I've done to most of my older widgets.

  21. The Following User Says Thank You to NewD For This Useful Post:

    #m37h{ (2015-01-25)

  22. #313
    Quote Originally Posted by NewdestinyX View Post
    The workaround in post#1 and 2 doesn't not address the SIZING of your widgets, Meth.. And Simon is right to point out that if you're using June's VIEWPORT code in the HTML it gets broken by using GL+/GB+..

    SO - if you want to bring an old iPhone 4/5 sized widget to iphone 6 or 6+ follow the instruction I placed in Post #3 of this thread... That's one method to get your widget to size up properly. There are several ways to accomplish it - none of them 'easy' though when working with GB+/GL+.. June's code was 'easy' - but doesn't work in WKWebView which is the 'engine' GL+/GB+ use to get rid of your resprings. But look at post #3.. that's what I've done to most of my older widgets.
    i did not resize anything bro,not using old widget but uniaw7

  23. #314
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,708
    Thanks
    8,334
    Thanked 16,463 Times in 7,695 Posts

    Quote Originally Posted by meth357 View Post
    i did not resize anything bro,not using old widget but uniaw7
    Not sure what went wrong, Meth. I followed by instructions in Post #2 to the letter (the easy 'one line of code' change to GL+/GB+) and it worked perfectly - noweird sizing problems on my iPhone 6. Are you using the UniAW7 (for 4,5 6) from page one of Ian's thread? It the sizing set to "auto" in the config.js? My instructions in post #2 will convert it for GL+/GB+ perfectly. Go back and try the instructions again. That's all I can offer. It's worked for everyone so far.

    The "SWITCH" instruction I wrote in Post #4 do NOT work for UniAW7 - but I make that disclaimer at the top of post #4. I DO have a method to add a switch to UniAW7.. I can share that too if that's the issue.
    Last edited by NewD; 2015-01-25 at 04:58 PM.

  24. The Following User Says Thank You to NewD For This Useful Post:

    #m37h{ (2015-01-25)

  25. #315
    Quote Originally Posted by NewdestinyX View Post
    Not sure what went wrong, Meth. I followed by instructions in Post #2 to the letter (the easy 'one line of code' change to GL+/GB+) and it worked perfectly - noweird sizing problems on my iPhone 6. Are you using the UniAW7 (for 4,5 6) from page one of Ian's thread? It the sizing set to "auto" in the config.js? My instructions in post #2 will convert it for GL+/GB+ perfectly. Go back and try the instructions again. That's all I can offer. It's worked for everyone so far.

    The "SWITCH" instruction I wrote in Post #4 do NOT work for UniAW7 - but I make that disclaimer at the top of post #4. I DO have a method to add a switch to UniAW7.. I can share that too if that's the issue.
    thanx ,did everything twice i am sure all is correct,but i am using ip6 only css

  26. #316
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,708
    Thanks
    8,334
    Thanked 16,463 Times in 7,695 Posts

    Quote Originally Posted by meth357 View Post
    thanx ,did everything twice i am sure all is correct,but i am using ip6 only css
    Shouldn't make a difference, Meth. Whether I use "auto" or "iPh6" css call - both work for me. Zip up and post for me here your style6.css and main.js files.. And let me see what might have gone wrong.

  27. #317
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Lockbackground.html may be worth a look too just in case.

  28. #318
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,708
    Thanks
    8,334
    Thanked 16,463 Times in 7,695 Posts

    Default Workaround Stategies for iOS8 respringing using GroovyAPI+
    Quote Originally Posted by rasputin007 View Post
    @Grant
    OK, our definition of auto-updating are different. You look at a constant GPS monitoring with GPS update as soon as your current location is "significantly" different from the last saved GPS position. I guess I understand auto-updating as a process whereby the GPS position gets updated without user intervention, it gets updated automatically.
    We have the exact same definition, Ras. . WW provides exact location to the meter (not 'significant change at all) WITHOUT any interaction from the user - not even 'opening the LS'. Your/June's code requires opening your phone to do the act of updating. That is an EXTRA step to attain the GPS. WW doesn't need any interaction from the user to get exact pinpoint location to the phone.
    The cycript code does NOT monitor GPS it just gets the GPS position for the location where you opened the cydget theme.
    As both, cycript code and WW2, tap into the iOS location.framework, they don't differ much in their way to get info. WW2 uses the GPS monitoring feature that the location.framework provides. This is not enabled in the cycript code (activelyTracking:NO).
    Understood. We agree there too.

    My original question was "which other theme gives you a on-the-spot GPS location update every time you run it" and your answer "WW2 can, of course." To which I replied that you have not answered my question as WW2 is not a theme. Now you are saying "who said otherwise? Not me." And you still have not answered my question.
    You have still misunderstood. Firstly Epic Cydget and your widget are not really THEMES per se.. They are 'widgets'. They use the tweak Cycript to access the GPS data. There are hundreds of WIDGETS out there that are not Cydgets that access the GPS data by use of the TWEAK WW2. Epic Cydget is a WIDGET(theme, as you call them).. just like UniAW7 is a WIDGET/theme.. The 'tweak' they each use are different (Cycript or WW2) but they still BOTH use a "tweak" to access GPS data.. So, again, I answered your question with great specificity, bro. If you don't accept that there is no difference in the 'theme versus tweak' distinction I am making then I guess we'll just need to agree to disagree, agreeably..

    Now regarding what is "superior" (your words), I just could not leave your statement that WW2 is ahead of cycript as such, hence my comment that the fact that GPS gets updated every time you activate the LS puts it ahead of every thing else. Kind of bite-back.
    Okay.. Well.. you know me.. I can't accept false statements without 'challenging them'.. I think we're similar in that way. The fact remains WW2 can accomplish something Cycript canNOT with regard to auto updating. That's why I use WW2 over Cycript or Epic Cydget. WW2 is a 'superior' product for my needs. And I believe for the general user's needs too. But that's just my opinion. I just need you and June to stay intellectually honest when you explain the differences. June claimed that Epic Cydget works "without the need for any other tweaks". That is just as much a fallacy today as it was on Day 1.

    Anyway we are starting to compare pears with bananas. WW2 does much more then monitoring GPS, it is a standalone tweak. The cycript code is bound to cydget platform and for LS only, at least the code I am using.
    Cydget is a theme player and can run WITHOUT cycript. GroovyLock is a theme player and can run without WW2... OF course we both know that both theme (HTML) players work better with 'their engines' (Cycript and WW2).

    We're at the point of a 'circular' argument now, my good colleague. So we can stop.

    Hey - I would still love to try your tweak/widget -- whatever... LOL!!... Because I learn a lot from your coding technique.. When you're ready to release - please release here.. Or PM to me..

    Thanks!
    Last edited by NewD; 2015-01-30 at 03:43 AM.

  29. #319
    @Grant
    An update on the WeatherUnderground (WU) front.
    The App Store app Living Earth (paid app) uses WU and works just like the iOS 8 Weather app, with custom set locations and one GPS location. It has a "background app" switch to allow updating while not running.
    I found the plist file that stores all the updated data and can extract them, but that will take quite a while as the gps location part alone contains about 33.000 lines of code (as xml file), 10 day forecast with hourly forecast for the next 5 days. LOL
    Last edited by rasputin007; 2015-01-30 at 12:16 PM.
    Nothing is impossible only miracles take a bit longer!

  30. #320
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,708
    Thanks
    8,334
    Thanked 16,463 Times in 7,695 Posts

    Default Workaround Stategies for iOS8 respringing using GroovyAPI+
    Quote Originally Posted by rasputin007 View Post
    @Grant
    An update on the WeatherUnderground (WU) front.
    The App Store app Living Earth (paid app) uses WU and works just like the iOS 8 Weather app, with custom set locations and one GPS location. It has a "background app" switch to allow updating while not running.
    I found the plist file that stores all the updated data and can extract them, but that will take quite a while as the gps location part alone contains about 33.000 lines of code (as xml file), 10 day forecast with hourly forecast for the next 5 days. LOL
    Wow!!! Sounds interesting Ras.. I'll check out that app.. Hey do you have any idea why when doing the JQuery call to WU I can simply use the syntax 'JQuery.get(......,)' to parse the data from the feed.... But when, for testing purposes (not wanting to use up my raindrops for too many calls to WU per day) I put the json result data in a .txt file - but getting that data requires JQuery.getJSON(......)?

    Do you know why a JSON response file saved as text locally would require a different call syntax?
    Last edited by NewD; 2015-01-30 at 03:14 PM.

Page 16 of 42 FirstFirst ... 6141516171826 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •