Little bit background of my iPhone:
iPhone 3GS 16GB
Version: 4.2.1
Firmware: 06.15.00
I was using an application called "CP Pro" for taking pictures on my iPhone. A truly awesome application with better quality. Well, after taking all the pictures, I plugged in my iPhone to iTunes and somehow it lost the application including all the pictures and videos. iTunes didn't have any backup unfortunately. I have tried every single thing to get the pictures out of my phone using SSh method:

ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=iphone-dump.img

ssh [email protected] dd if=/dev/rdisk0s1 bs=1M | dd of=iphone-root.img

ssh [email protected] dd if=/dev/rdisk0s2s1 bs=1M | dd of=iphone-user.img

After mounting the img file and scanning through Steller Phoenix, Phonerec or Data Rescue III, it doesn't find any data. I have not restored my cell phone that would make any possibility to overwrite the data. Also, the phone has 16GB hard drive and 13GB is still available. I have tried with bs=1M and bs=4096KB, not sure if it'll make any difference. I would really appreciate your help or even I'm willing to pay if there are any services available to recover data from iPhone.