Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Can no longer SSH... anyone else?

  1. #1
    Default Can no longer SSH... anyone else?
    About a week ago I stopped being able to use WinSCP to get into my iPhone. It's not the PC as I have WinSCP on several of them--all can no longer access the iPhone.

    Have restored my iPhone, tried installing (separately) both OpenSSH and dropbear to no avail--and each showed as running UIctl. Have reinstalled BSDSubsystem multiple times. Get nothing from WinSCP except a timeout.

    Anyone have any ideas? This is getting frustrating.


    --
    Mike

  2. #2
    PC or MAC? Need more info.

  3. The Following User Says Thank You to XFaega For This Useful Post:

    Tinman (2007-09-23)

  4. #3
    Quote Originally Posted by XFaega View Post
    PC or MAC? Need more info.
    PC. Does WinSCP even run under OS X?


    --
    Mike-

  5. #4
    Retired Moderator jedinight's Avatar
    Join Date
    Jul 2007
    Location
    c.s. texas
    Posts
    969
    Thanks
    49
    Thanked 113 Times in 89 Posts

    ive had this problem berfore ,....i had a problem where my ip address listed in the iphone wasent what my wifi routers said it was..so ipunched in the ip address listed in my router .then it connected..then i closed winscp and looked on my phone and it had changed...wierd .oh yeah it took my hrs to figure it out

  6. The Following User Says Thank You to jedinight For This Useful Post:

    Tinman (2007-09-23)

  7. #5
    Quote Originally Posted by jjgsxr883 View Post
    ive had this problem berfore ,....i had a problem where my ip address listed in the iphone wasent what my wifi routers said it was..so ipunched in the ip address listed in my router .then it connected..then i closed winscp and looked on my phone and it had changed...wierd .oh yeah it took my hrs to figure it out
    Thanks, but I use a static IP on my iPhone specifically for SSH.

    The only thing that I can remember updating is Summerboard and iTunes.


    --
    Mike

  8. #6
    What's Jailbreak?
    Join Date
    Jun 2007
    Location
    College Station
    Posts
    5
    Thanks
    0
    Thanked 4 Times in 2 Posts

    it could be that WinSCP doesn't know/won't accept your new host key generated by your iphone after your reformated and reinstalled openssh, so i would dig through preferences for something related to that, just a thought.

  9. #7
    Well I tried starting from scratch and it's still no-go. Very weird since I have had SSH on my iPhone since July--and it's always worked.

    Since yesterday I have tried the following:
    * Updated WinSCP to 4.04. No change.

    * Uninstalled and reinstalled dropbear. No change.

    * Uninstalled and reinstalled OpenSSH. No change.

    *Restored the iPhone again and tried the above yet again.


    I should note that I was using dropbear without issue. I only tried OpenSSH after dropbear (apparently) stopped working.

    WinSCP never gets past "Searching for host..." which always ends with "Network error: Connection timed out."

    So it seems like my iPhone is not even being seen by WinSCP. Oh yea, I have turned the firewall completly off on my PCs while trying to get this ironed out.

    Does anyone know of perhaps a non-SCP app for PCs that has better file access than iBrickr? I could get by without SSH (for now at least) if I had something other than iBrickr to use for file management.


    --
    Mike

  10. #8
    I had this problem with Cyberduck on OS X, i switched to Fugu and it accepts it no prob......who knows lol

  11. #9
    Just wanted to update this thread for closure.

    Turns out I spent all of the time restoring for nothing. The issue was, apparently, with my static IP address.

    After realizing that I couldn't access my iPhone at all via TCP/IP (even to use Apache on the iPhone) I decided to just forget all of my network settings. When I set my WLAN connection back up again I let it use DHCP... Wham, I could use SSH again without issue. This is odd since I had been using the same static IP for around 2 months without issue. Since I don't want to rely on a DHCP-assigned IP, I again changed my iPhone back to using a static IP--and it still works fine.

    Anyhoo it's working fine now. Thanks for the replies.




    --
    Mike

  12. #10
    same problem here, my winscp just stopped working for no apparent reason, I have been using winscp for months now without any kind of problem.......VERY STRANGE.

    can somebody please help!!! is there another program I can wirelessly ssh under windows beside winscp?

    I recently installed the latest version of winscp to no avail, I just don't understand it!!! I have BSDsubsystem/Openssh/ bossPrefs all installed working perfectly together without a hitch. I did however recently increase the security of my wifi network from wep128 to wpa2 psk(aes), does that effect it in anyway? it shouldn't IMO as I have always given my firewall permission to let winscp access the network. As I have said it before, it never used to be an issue until now.

    sometimes winscp manages to connect into the iphone but then when I try to go back to the iphone's root directory, it just hangs there and then maybe after 15sec or so, I'm prompted with a connection error message and a choice to reconnect again. This is very frustrating. I hope you guys that know more on this can help me resolve this situation.

    thanks!!


    currently using firmware 1.1.2
    Last edited by swifty7; 2008-06-14 at 08:10 AM.

  13. #11
    simple test to see if its ur network or phone:

    try opening up a command prompt or terminal and ping the ip address of the iphone, if u get a reply, then the iphone and network is fine, then for winscp check to make sure ur connecting via scp(as this always works for me, you can use sftp but may get errors from time to time)

    also make sure if using bossprefs to ensure ssh is on (just because something is installed dont me its on-although it is by default)

    if that fails try these two options, revert back to the old winscp

    use different computer and or wireless network

    un install and re install ssh

    hope that works =]

  14. #12
    first of all.....thanks for your suggestions!

    it looks like it's working for now, what I did was:

    1) I re-entered the ip number(192.168.1.4) and password(alpine)

    2) using SFTP with the option to allow SCP fallback.

    so far so good I just hope it stays that way.


    THANKS AGAIN!!

  15. #13
    it looks like I'm back to square one, ssh is giving me a hard time again.....damn it!!!

    I uninstalled/installed openssh again to no avail .

  16. #14
    update:

    SSH works like a charm now!

    the problem was a miss-comunication between my iphone and the router, apparently the signal channel{11) I had set my router to was giving problems, maybe some interference by some other router. So I decided to change my router channel back to 6 and now everything works great. Always make sure to check your router first before deciding to restore or uninstall/install apps.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •