Page 53 of 76 FirstFirst ... 343515253545563 ... LastLast
Results 1,041 to 1,060 of 1517

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Enable Video Recording on 2G/3G?

  1. #1041
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Michigan
    Posts
    289
    Thanks
    9
    Thanked 28 Times in 23 Posts

    Ok, everyone, I made it so that cycorder saves videos to the 100apple file location, but the only thing is that I think when setting the permissions, you have to also set it to true, will ssh wont work on my computer for some reason, so I will post the file if someone knows how to set it to true, I think thats what you set it to!

    I know I post alot, ok, so I don't remember who it was, but someone here got the shutter to open, but they saw a black screen! I think I have the solution for the black screen! Inside cycorder, I found this through hex edit: "setBackgroundColor: clearColor", this may mean that inside mobileslideshow.app or photolibrary, there may be a line of code that says setbackgroundcolor: blackcolor and all we would have had to do was change it to clearcolor, so the person who had gotten that far, can you please try that! Thanks!


    Edit: another discovery: looks like our friend who owns cycorder made his picture files into the hex using a program like this: http://www.softpedia.com/get/Multime...o-Hex-II.shtml

    So, we need to find a program that can do the opposite which is take a hex and make a picture!
    Last edited by ryanandkevin; 2009-10-10 at 05:34 AM. Reason: Automerged Doublepost

  2. #1042
    What's Jailbreak?
    Join Date
    Jul 2009
    Location
    LA
    Posts
    16
    Thanks
    2
    Thanked 1 Time in 1 Post
    Quote Originally Posted by ryanandkevin View Post
    Also, if you guys want more ram, delete apps that you don't need/like, like stocks, mail (If you dont use it), maps (I have navigon), notes, that will free up alot of ram, giving you more ram to run native video recording or voice control
    how to delete stocks and maps? could you tell me please?

  3. #1043
    My iPhone is a Part of Me mkblade's Avatar
    Join Date
    Nov 2007
    Location
    on Earth
    Posts
    600
    Thanks
    46
    Thanked 112 Times in 66 Posts

    if u think its just the signing issue..thne here's how to sign:
    1)Open Cydia and search for "MobileTerminal" first then "ldid" and install those two
    2)Open MT (Mobile Terminal) and type: ldid -s whatever
    It should give you something (some error) OTHER than an an unknown command, if you do get an unknown command, type this: apt-get ldid
    3)Navigate/change directory to the files that need to be changed..
    (ex/ cd /System/Library/PrivateFrameworks/ etc....) making sure to type the names as is and correctly
    4)Once the directory has been changed, type the file name that would be in that particular directory...and type: ldid -s file [replaing "file" with that particular binary file]
    5)Do this as many times as needed for all files
    6)Finally at the end, type: killall SpringBoard


    *EDIT* ryanandkevin...you are right about one thing..inside MobileSlideShow binary it does say setBackgroundColor: BlackColor

    *EDIT2** Tried replacing black with clear..however when i select camera now it just instantly crashes down...will try the signing process on it though doubt it justs signing...

    *EDIT3* Now that I signed MobileSlide and Camera binary...it seems to open 75% of the way up to where the screen shows up (camera screen) then it instantly crashes down again....hmmm..
    Last edited by mkblade; 2009-10-10 at 03:16 PM.

  4. #1044
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Michigan
    Posts
    289
    Thanks
    9
    Thanked 28 Times in 23 Posts

    wait, so the shutter opened up 75% and then crashes?

    mkblade, Can you post all the files that you have so far that you have edited or changed in your iphone so that you can at least see the video recording switch, because my iphone becomes an ipod touch when I try it! Also, what firmwire are you on? Thanks!
    Last edited by ryanandkevin; 2009-10-10 at 06:47 PM. Reason: Automerged Doublepost

  5. #1045
    iPhoneaholic
    Join Date
    Apr 2008
    Location
    Peters Twp, PA
    Posts
    314
    Thanks
    9
    Thanked 30 Times in 27 Posts

    Quote Originally Posted by mkblade View Post
    if u think its just the signing issue..thne here's how to sign:
    1)Open Cydia and search for "MobileTerminal" first then "ldid" and install those two
    2)Open MT (Mobile Terminal) and type: ldid -s whatever
    It should give you something (some error) OTHER than an an unknown command, if you do get an unknown command, type this: apt-get ldid
    3)Navigate/change directory to the files that need to be changed..
    (ex/ cd /System/Library/PrivateFrameworks/ etc....) making sure to type the names as is and correctly
    4)Once the directory has been changed, type the file name that would be in that particular directory...and type: ldid -s file [replaing "file" with that particular binary file]
    5)Do this as many times as needed for all files
    6)Finally at the end, type: killall SpringBoard


    *EDIT* ryanandkevin...you are right about one thing..inside MobileSlideShow binary it does say setBackgroundColor: BlackColor

    *EDIT2** Tried replacing black with clear..however when i select camera now it just instantly crashes down...will try the signing process on it though doubt it justs signing...

    *EDIT3* Now that I signed MobileSlide and Camera binary...it seems to open 75% of the way up to where the screen shows up (camera screen) then it instantly crashes down again....hmmm..
    o0o. sounds like progress! keep me posted!

  6. #1046
    iPhone? More like MyPhone OLIVERJONES's Avatar
    Join Date
    Jun 2009
    Location
    Scotland, UK
    Posts
    106
    Thanks
    22
    Thanked 17 Times in 14 Posts

    Sorry People i was called in to work on a Saturday and am quite mad at it, i am still here now but taken 5 mins to leave this post. Well it seams like mkblade and ryanandkevin you are SOOOO close to getting this to work i can feel it coming and mkblade you said the the shutter opens 75% then crashes is yes, that happened with me back on pg 44 (there abouts) and i could not get around it so i edited the springboard.app then my iphone broke so i restored and never could repeat the steps to do this. But i think the reason it crashes is that some file is instructing the camera preview at 3mp (3GS) and not at 2mp (3G/2G) so if you could edit the photo and video files that command this it may work. Please keep us informed as i think we are almost there (well yous are). And mkblade if you could email or message a link to my and ryanandkevins email or even post them (only if you want) so that we can test them (but i am away next week).
    i am sorry that i could not post those files and it is unlikely i will be able to post them before i am away :/ very sorry about this.

    Good Luck i feel we are almost there (Y)

    Oliver.

    My email for files or contact:- [email protected]

  7. #1047
    My iPhone is a Part of Me mkblade's Avatar
    Join Date
    Nov 2007
    Location
    on Earth
    Posts
    600
    Thanks
    46
    Thanked 112 Times in 66 Posts

    Would love to post right now but am at work

  8. #1048
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Michigan
    Posts
    289
    Thanks
    9
    Thanked 28 Times in 23 Posts

    mkblade, what firmwire are you on and does the shutter open 75 percent and can you see the world through the camera, you know what I mean? Or the app opens 75%

    ok, you only edited mobileslideshow app, you also have to edit photlibrary to ClearColor, I checked it and its in there also, thats probably why it only loads 75% because 75% of the app is from mobileslidshow and the other 25% is from photolibrary!
    Last edited by ryanandkevin; 2009-10-10 at 07:56 PM. Reason: Automerged Doublepost

  9. #1049
    iPhone? More like MyPhone OLIVERJONES's Avatar
    Join Date
    Jun 2009
    Location
    Scotland, UK
    Posts
    106
    Thanks
    22
    Thanked 17 Times in 14 Posts

    ^^ @mkblade Same i am at work on a saturday to lol but will be home soon
    @ryanandkevin when i was on 3.0 and just started work on this (spent 30 hours on it straight ) i got the shutter opening 75% ish then the camera app crashed then i edited something in the springboard then my iphone broke so i restored and never got it to do that again but thats true 25% is photo library (I) so thats the part we need to look at, if its the right guess but should be

    Oliver.

  10. #1050
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Michigan
    Posts
    289
    Thanks
    9
    Thanked 28 Times in 23 Posts

    actually that is probably it, apple probably created a plist file that stated to add blackcolor to the binary's of the app if video-camera was ever added to that certain plist, so now all we have to do is for everything dealing with the camera app, we switch it from blackcolor to clearcolor and we sign the files!

    and when you got the shutter to open, it was a black screen, or in this case setbackgroundcolor: blackcolor!
    Last edited by ryanandkevin; 2009-10-10 at 08:07 PM. Reason: Automerged Doublepost

  11. #1051
    iPhone? More like MyPhone OLIVERJONES's Avatar
    Join Date
    Jun 2009
    Location
    Scotland, UK
    Posts
    106
    Thanks
    22
    Thanked 17 Times in 14 Posts

    Ohhh yass well done ryanankevin think that it !!!! Think we will need the encoders etc for it too work but yes that wud open the shutter imagie it as an black picture over the preview change it too invisible the shutter problem done !!! Think Thats it I feel it coming ryanandkevin do you think you could do that ?? Ie change the colour ?? If sobplease go ahead I will b home in 20min faster if I put my foot down

    Good Good Luck

    Oliver.

  12. #1052
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Michigan
    Posts
    289
    Thanks
    9
    Thanked 28 Times in 23 Posts

    I can change the color but, I can't get my camera app moded to the 3gs, whenever I try, it turns my iphone into an ipod touch, I'm on 3.1, so then I went back to 3.0 and it did the same thing! This may be a system file issue that stays the same, kind of like the baseband! Is there any way to put the iphone back to its virgin state? I think there is, let me search?

  13. #1053
    iPhone? More like MyPhone
    Join Date
    Feb 2009
    Location
    Wouldn't you like to know ;)
    Posts
    215
    Thanks
    48
    Thanked 16 Times in 12 Posts

    i wouldnt mind being a beta tester for this. i dont care if i need to restore several times a day

  14. #1054
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Michigan
    Posts
    289
    Thanks
    9
    Thanked 28 Times in 23 Posts

    I'm not sure if where going to need beta testers, because when we finish, its probably just going to be a full featured release, because if it works, it works

  15. #1055
    iPhone? More like MyPhone
    Join Date
    Feb 2009
    Location
    Wouldn't you like to know ;)
    Posts
    215
    Thanks
    48
    Thanked 16 Times in 12 Posts

    K. if ya do, just lemie know

  16. #1056
    iPhone? More like MyPhone OLIVERJONES's Avatar
    Join Date
    Jun 2009
    Location
    Scotland, UK
    Posts
    106
    Thanks
    22
    Thanked 17 Times in 14 Posts

    Cool The Way Forward.
    Right People this post is a little fyi about getting native video recording from here and may i say we are now very close ... (maybe).

    Right these post i am going to says a combination of what mkblade, ryanandkevin, and my own plan for getting video recording to work (probably the best way to do so) and we think if we follow these steps (well manage to achieve them should be easy enough when you know how).

    1) (Photo of the black screen on 3.0 attached & at bottom, we need to achieve that on 3.1) We need to open the shutter by basically adding an arm6 signed version of the 3GS binaries with mobileslideshow and photolibrary, then some how in the springboard app with the M68, N82 and N88 plists add the video-camera string, therefore getting the shutter open but the screen would be black. mkblade achieved this on the 3.0 firmware and so did i (but only after him, and then gave up activating video recording that way as we thought files were missing, some images are attached about this) This only seems to work on the 3.0 firmware not 3.1. @mkblade can you get it go black again on 3.1 ?? or if anyone else can just leave a post saying how.when that is achieved proceed to the next step.

    2)Tonight ryanandkevin found out that there was a code (not sure what binary) that told the screen to go black it says setbackgroundcolor: BlackColor and ryanandkevin says if you changed it to ClearColor, that should enable video recording, but it needs to be done in both files and you must set permissions and sign the files. And that could be native video recording done and dusted. BUT we need to do part one first. @ryanandkevin is the only person who knows where these files are but if we could achieve part 1 would you change the background to clear for us or show people how to change the background clour ??

    Hopefully then native video recording would work on 3.1 , but i maybe wrong about it. But if you downgraded to 3.0 then carried out the first step which is much easier cause it actually works that way then did step 2 you may have native video recording.

    @mkblade (or anybody who knows how) i was not able to find the files i modded to get the screen to go back if you have them (for the 3.0) could you post them ? Then see if you can get the screen black like you did in the 3.0 (you posted screen clips several pages back) if you could do that it would be excellent.

    @ryanandkevin where abouts was the setbackgroundcolor: BlackColor stored was it in the mobileslideshow and photolibrary binaries (i assume it would be) ?



    then if yous put those steps together native video recording may work on the iPhone 2G/3G!

    Many Thanks to mkblade and ryanandkevin and everybody else who has been hellping with this so far

    Oliver.

    P.S. i will be away on holiday from tomorrow for 12ish days and may not have internet connection so excuse me if i don't reply. But i defiantly will not be able to work on this , apologies.
    Resources.

    CPU Value.:-

    If you dont know how to change the CPU value to arm6 from arm9 here's how.

    you need any hex editor

    go to a binary file (e.g. /Applications/MobileSlideShow.app/MobileSlideShow) then open it with the hex editor.

    the fist line of values will be e.g.
    CE FA ED FE 0C 00 00 00 09 00 00 00 02 00 00 00

    see that 9 highlighted ^^^
    change it to a 6 and save the file and thats it changed (i think not sure if thats 100% right, not too good at this lol)
    it now should look like
    CE FA ED FE 0C 00 00 00 06 00 00 00 02 00 00 00


    Signing Code. (thanks to Mkblade for this):-

    Quote From mkblade:
    if u think its just the signing issue..thne here's how to sign:
    1)Open Cydia and search for "MobileTerminal" first then "ldid" and install those two
    2)Open MT (Mobile Terminal) and type: ldid -s whatever
    It should give you something (some error) OTHER than an an unknown command, if you do get an unknown command, type this: apt-get ldid
    3)Navigate/change directory to the files that need to be changed..
    (ex/ cd /System/Library/PrivateFrameworks/ etc....) making sure to type the names as is and correctly
    4)Once the directory has been changed, type the file name that would be in that particular directory...and type: ldid -s file [replaing "file" with that particular binary file]
    5)Do this as many times as needed for all files
    6)Finally at the end, type: killall SpringBoard


    *EDIT* ryanandkevin...you are right about one thing..inside MobileSlideShow binary it does say setBackgroundColor: BlackColor

    *EDIT2** Tried replacing black with clear..however when i select camera now it just instantly crashes down...will try the signing process on it though doubt it justs signing...

    *EDIT3* Now that I signed MobileSlide and Camera binary...it seems to open 75% of the way up to where the screen shows up (camera screen) then it instantly crashes down again....hmmm..
    And for permissions on cyberduck (think winSCP too) just write click then you will see read write etc and click on them preferably to 777 (777 is located at the top and it means with all boxes ticked)

    Hope they help for those who don't know how to.

    Thanks to the people

    P.S. (THIS IMAGE IS WHAT WE WANT TO ACHIVE IN STEP 1 ON 3.1 )



    Good Luck People, I Feel It Coming

    Oliver.

    [email protected]


    ^^^ i will be watching, helping and posting about this when i am away (if i have internet connection) but please feel free to keep us updated on ideas etc, through email, while i am on holiday
    Attached Thumbnails Attached Thumbnails -img_0004.png  
    Last edited by OLIVERJONES; 2009-10-11 at 12:24 AM.

  17. The Following User Says Thank You to OLIVERJONES For This Useful Post:

    surfingboy111793 (2009-10-11)

  18. #1057
    My iPhone is a Part of Me mkblade's Avatar
    Join Date
    Nov 2007
    Location
    on Earth
    Posts
    600
    Thanks
    46
    Thanked 112 Times in 66 Posts

    to reply back to some questions:
    it is only the app which opened 75% of the way, not the shutter
    i also did the change on the photolibrary binary h/e still getting same responce...now am currently doing the signing to see if that has anything to do with it....nope..still getting same responce

    ryanandkevin..if u would like i can post my 2 plists which ive edited..bcuz ur saying urs turns into an ipod touch...i have the 2G with 3.1 installed/jb......no 3.1.2 yet...

  19. #1058
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Michigan
    Posts
    289
    Thanks
    9
    Thanked 28 Times in 23 Posts

    mkBlade, if you could post the plists, that would be great, thanks!

    Im only going to be online for a little longer, so if you could post them soon, that would be great! My internet is down at home, so I'm at our public library!

    mkblade, I'm online if you want to post the plists, thanks!

    Also, I can't find ldid in cydia, also is that an I, and L, or a 1, but still I cant find it in cydia!
    Last edited by ryanandkevin; 2009-10-12 at 01:13 AM. Reason: Automerged Doublepost

  20. #1059
    My iPhone is a Part of Me mkblade's Avatar
    Join Date
    Nov 2007
    Location
    on Earth
    Posts
    600
    Thanks
    46
    Thanked 112 Times in 66 Posts

    Quote Originally Posted by ryanandkevin View Post
    mkBlade, if you could post the plists, that would be great, thanks!

    Im only going to be online for a little longer, so if you could post them soon, that would be great! My internet is down at home, so I'm at our public library!

    mkblade, I'm online if you want to post the plists, thanks!

    Also, I can't find ldid in cydia, also is that an I, and L, or a 1, but still I cant find it in cydia!
    sry i couldnt post anything yest...things came up...but yea in cydia u should search for ldid (L-lowercase) and if it doesnt come up then go into "Development" section in Cydia and look for "Link Identity Editor"...which is what ldid is... If its still not there then u might need to update/add sources

  21. #1060
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Michigan
    Posts
    289
    Thanks
    9
    Thanked 28 Times in 23 Posts

    If you could post them right now, that would be great! Thanks!

    There not showing up
    Last edited by ryanandkevin; 2009-10-12 at 04:37 PM. Reason: Automerged Doublepost

Page 53 of 76 FirstFirst ... 343515253545563 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •