Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: "." Shortcut quit working

  1. #1
    Default "." Shortcut quit working
    Hey all. Thanks for your time in considering this: all of a sudden my "." Shortcut quit working. When I double tap the spacebar with this set to on, all it does is insert two spaces. Auto-correction, Auto-cap, and Enable Caps Lock all are working fine; just not the "." I have utilized the search function to no avail. My keyboard.plist appears to be okay, as does TextInput_en.bundle in /System/Library/TextInput. I am running an iPhone 3G 2.2 jailbroken. I have absolutely no other problems with the phone except this. I am at a loss as to understand the idea why this is happening. If someone could attach a Keyboard.plist and their /System/Library/TextInput directory, I could try that...I just don't know. Also, I have no keyboard enhancements or themes installed. Any help would be much appreciated. Thanks!

  2. #2
    Livin the iPhone Life SharpieBandit's Avatar
    Join Date
    Sep 2008
    Location
    Alexandria, Louisiana
    Posts
    1,454
    Thanks
    53
    Thanked 76 Times in 63 Posts

    I don't wanna sound like a jerk, but is it set to "On" in your settings? I've restored my phone and didn't realize it isn't set to "On" by default.
    Steam ID: gentrytj
    Origin ID: gentrytj
    Gamertag: TJ McHoonigan
    PSN ID: TheWyzeMan
    Twitch.TV: TJ_McHoonigan

  3. #3
    LOL, yeah I made sure the toggle is set to on. I know sometimes it's the little things that slip by. I've even turned it off, rebooted, turned it back on, rebooted, and any combination of that you could think of. Thanks for the reply though.

  4. #4
    Livin the iPhone Life SharpieBandit's Avatar
    Join Date
    Sep 2008
    Location
    Alexandria, Louisiana
    Posts
    1,454
    Thanks
    53
    Thanked 76 Times in 63 Posts

    Maybe try the permissions fix that is inside SBSettings?
    Steam ID: gentrytj
    Origin ID: gentrytj
    Gamertag: TJ McHoonigan
    PSN ID: TheWyzeMan
    Twitch.TV: TJ_McHoonigan

  5. #5
    My iPhone is a Part of Me IvanPK's Avatar
    Join Date
    Apr 2008
    Location
    USA
    Posts
    611
    Thanks
    56
    Thanked 47 Times in 44 Posts

    Yeah mine stopped working as well, wtf?

    I turned mine off, exited Settings then tried it, it didn't work. then i put it back to 'ON' and it worked. Try that? (im sure you already have though)
    Last edited by IvanPK; 2009-04-03 at 02:04 AM. Reason: Automerged Doublepost

  6. #6
    @Sharpie: I've not tried that yet. Does doing that run any kind of irreparable risk? And do you think it might work?

    @Ivan: Yeah, I've tried that numerous times with no change.

    Any luck with anyone willing to post those files from my first post? TIA!

  7. #7
    Livin the iPhone Life SharpieBandit's Avatar
    Join Date
    Sep 2008
    Location
    Alexandria, Louisiana
    Posts
    1,454
    Thanks
    53
    Thanked 76 Times in 63 Posts

    I don't have a 3G or I would....

    And it *might* work. I don't see how it would, but then again why not try? No, it doesn't cause any irreparable damage.
    Steam ID: gentrytj
    Origin ID: gentrytj
    Gamertag: TJ McHoonigan
    PSN ID: TheWyzeMan
    Twitch.TV: TJ_McHoonigan

  8. The Following User Says Thank You to SharpieBandit For This Useful Post:

    oz0ne (2009-04-05)

  9. #8
    My iPhone is a Part of Me IvanPK's Avatar
    Join Date
    Apr 2008
    Location
    USA
    Posts
    611
    Thanks
    56
    Thanked 47 Times in 44 Posts

    where is keyboard.plist and do you want the entire text input directory or just textinput_en.bundle

  10. #9
    My iPhone is a Part of Me IvanPK's Avatar
    Join Date
    Apr 2008
    Location
    USA
    Posts
    611
    Thanks
    56
    Thanked 47 Times in 44 Posts

    here ya go
    Attached Files Attached Files

  11. The Following User Says Thank You to IvanPK For This Useful Post:

    oz0ne (2009-04-05)

  12. #10
    @Ivan: Keyboard.plist is located in /Apllications/Preferences.app
    And thanks for uploading that textinput bundle. I greatly appreciate it. Unfortunately, it didn't work. Ah well...

    @Sharpie: I gave it a shot but still no luck. Everything else seems fine though.

    Thanks for your input guys. If the Keyboard.plist doesn't work, any other ideas?

  13. #11
    Quote Originally Posted by oz0ne View Post
    @Ivan: Keyboard.plist is located in /Apllications/Preferences.app
    And thanks for uploading that textinput bundle. I greatly appreciate it. Unfortunately, it didn't work. Ah well...

    @Sharpie: I gave it a shot but still no luck. Everything else seems fine though.

    Thanks for your input guys. If the Keyboard.plist doesn't work, any other ideas?
    I know you don't want to hear the word but try a restore

  14. #12
    Nah, it's not a big enough deal to justify a restore. It's just aggravating; but doing a restore would be even worse!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •