Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Disable Auto-Play when Connecting to Car FM Transmitter

  1. #1
    Default Disable Auto-Play when Connecting Headphones
    Whenever I connect my iPhone to the stock headphones or to my car FM transmitter (Griffin iTrip Auto) it automatically starts playing songs from iPod.

    Anybody knows how to disable this "feature"?
    Last edited by roeeb; 2009-02-15 at 07:38 AM. Reason: Added headphones to problematic connections

  2. #2
    I have the same problem when I plug it into my dock, and when I plug the stock headphones in. It's really annoying, but I haven't found a solution yet. I'll pm you if I find one.

  3. #3
    You are correct, it also happens with the headphones (I updated the first post).

    I will also update here if I find something.

  4. #4
    I found a quick fix. Just install the ipod play/pause toggle for SBsettings and use it to play the ipod just before connecting the iphone. After it's connected, you can easily pause the music again and that way it doesn't open up the ipod page or take up as much memory.

    It works for my purposes, but I would still like to see the feature altogether disabled. I'll keep researching it.



    EDIT:
    I think I found the path where the option to disable the feature, if it exists, would be: /private/var/mobile/Library/Preferences


    Maybe in com.apple.springboard, com.apple.audio, or com.apple.preferences, I'll be browsing through them and I'll post here if I find anything.
    Last edited by Wingman13; 2009-02-16 at 08:24 PM. Reason: Automerged Doublepost

  5. #5
    I also tried looking for some settings at Aplications/Preferences.app/*plist or any other *plist under Applications/* but I couldn't find what we are looking for.

    It might not be as easy as editing plist files...

  6. #6
    I may be wrong but I think it's a hardware design issue. The controls on the earphones work by shorting the leads together. The same thing happens while inserting any plug.

  7. #7
    It is still the software which decides whether to launch iPod or not...

  8. #8
    maybe if we could create a toggle for SBsettings that disables mediaplayer altogether...


    EDIT: Ok, new revelation. Just delete MediaPlayer and install PwnPlayer, there, problem solved

    EDIT2: Nvm, don't do that, it corrupted my mobilemusicplayer.app and now I can't reinstall it I guess I have to restore...

    EDIT3: Woo, I managed to fix it by editing the octals
    Last edited by Wingman13; 2009-02-22 at 08:11 AM.

  9. #9

    EDIT3: Woo, I managed to fix it by editing the octals
    You edited the preferences, or you fixed the app you had corrupted? I've found some docking devices automatically play, which is a pain in the neck.. and others don't, which is the behavior I want. I figured this was a function of the doc, but with your posts, I get the impression that there might be a way to control this behavior with software...

    Thanks!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •