Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: "The Requested Modifications Cannot Be Applied Due to Required Dependencies"?

  1. #1
    Default "The Requested Modifications Cannot Be Applied Due to Required Dependencies"?
    Hey gang-

    Upgraded my iPhone 3gs today from 4.3.1 to 4.3.3 and then jailbroke with Jailbreakme.com. Worked great.

    Then logged into Cydia "Manage Account". It correctly listed all my purchased Cydia apps. But when I click on any of them to install, I get the error message:
    "The Requested Modifications Cannot Be Applied Due to Required Dependencies"

    What's crazy is that under Depends it says "iPhone firmware >= 3.0" Well this is a 3gs running 4.3.3, so not sure how it could be failing on that.

    I've rebooted the phone several times but no help. I'm stumped.

    Kupe
    Last edited by Kupe; 2011-07-13 at 06:15 AM.

  2. #2
    Retired Moderator Cer0's Avatar
    Join Date
    Apr 2008
    Location
    MN/WI
    Posts
    14,099
    Thanks
    395
    Thanked 1,182 Times in 915 Posts

    Do they rely on a different mod to be installed?
    [CENTER][SIGPIC][/SIGPIC][/CENTER]

  3. #3
    Quote Originally Posted by Cer0 View Post
    Do they rely on a different mod to be installed?
    Not that I am aware of. My three purchased apps are MyWi, PkgBackup, and Display Out. All pretty vanilla, mainstream Cydia stuff. All appear as Purchased apps in Cydia "Manage Account", but all fail to install with that error message.

    Kupe

    Edit- I'm starting to wonder if this isn't an outage at one of the Repos. Normally Cydia will automatically locate and install any dependent files when restoring from "Manage Account". So it shouldn't be possible to get this error when you think about it that way.

    I'll try again tomorrow.
    Last edited by Kupe; 2011-07-13 at 07:07 AM.

  4. #4
    If you have sshd running, (or MobileTerminal) and can get a shell-
    try running:

    $ apt-cache depends com.mywi4
    and
    $ apt-cache unmet com.mywi4

    And see what dependencies they assert, and which dependencies are UNMET.

    Maybe check versions on your installed packages (that seem to be dependencies):
    $ dpkg -l firmware mobilesubstrate com.intelli.statusbaricons openssl

    Edit:
    Or try again tomorrow!
    Last edited by raduga; 2011-07-13 at 07:23 AM.

  5. #5
    Sounds like a repo problem. You have the correct sources installed don't you?

  6. #6
    Quote Originally Posted by Iphone4noob View Post
    Sounds like a repo problem. You have the correct sources installed don't you?
    Turns out one of the major repos happened to be down or overloaded that night. So Cydia wasn't able to install the required dependent files. Worked find the next day.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •